Ask Your Question
0

How to startX (show desktop GUI) on VirtualBox / VMWare ?

asked 2011-10-14 15:20:19 -0500

supertat gravatar image

updated 2011-10-14 15:25:06 -0500

Hi, experts.

I tried both VirtualBox and VMWare to use Sage 4.7.1 on Windows.
But both of them starts up with CUI (Character User Interface).
Uploaded the screenshot at
- VirtualBox: http://blog-imgs-24.fc2.com/e/u/r/eurekass/vb.jpg
- VMWare: http://blog-imgs-24.fc2.com/e/u/r/eurekass/vmw.jpg

I tried the command "startx", but the error "command not found." returned.

Is there any way to startX (show desktop GUI) like LiveCD version ?

edit retag flag offensive close merge delete

Comments

That's really odd. The notebook server started, and if a browser doesn't open, you should at least be able to open a browser in the VM - but in this case, apparently something immediately quit the server within 30 seconds of it starting. Were you holding down some key combination, just on an off chance?

kcrisman gravatar imagekcrisman ( 2011-10-14 16:18:58 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
4

answered 2011-10-17 01:51:30 -0500

Volker Braun gravatar image

updated 2011-10-17 23:52:24 -0500

The images don't have a graphical user interface installed to save space. The idea is that only the Sage process is running in the virtual machine, and notebooks are displayed using the host's web browser. You can also share directories with the virtual machine and ssh into the virtual machine, for the record. So you can access pretty much everything from the host machine.

If you really wanted to run a full graphical desktop in the virtual machine, you could just use the package manager to install it:

sudo yum groupinstall "X Window System" "GNOME Desktop Environment"

This will install everything necessary for a graphical desktop. However, the virtual harddisk space is very limited. I tried this command and it failed due to insufficient space. One could try to resize the harddisk, but it is probably easier to install a fresh virtual machine from scratch.

edit flag offensive delete link more

Comments

How do you connect to the server by ssh?

Ioannis Souldatos gravatar imageIoannis Souldatos ( 2011-11-01 09:30:55 -0500 )edit

The ssh server in the virtual machine is listening on port 2222. Using OpenSSH, for exampel, you would connect via "ssh -p 2222 sage@localhost" from the host machine.

Volker Braun gravatar imageVolker Braun ( 2011-12-03 21:27:02 -0500 )edit
1

answered 2011-10-24 20:18:26 -0500

Emil Widmann gravatar image

If you feel more comfortable to run a sage-VM with a GUI try this image (400 MB) (unzip it to get a VMware image). This VM is handcrafted for desktop use, e.g. on windows computer. It is application only and has no development files and it is single user, i.e. it is not possible to setup a multi-user sage server.

For long term use it might therefore pay off to get comfortable with the CLI interface and use the official machine, which has the full package with all features. As stated above: the GUI is superfluous eye candy.

edit flag offensive delete link more

Comments

I should add that there is this new version of a GUI VM (ova format) http://boxen.math.washington.edu/home/emil/doc/html/en/relase-notes-slvms-b.htm.htm and also - based on this - a combined virtualbox/vm installer

Emil Widmann gravatar imageEmil Widmann ( 2011-12-03 10:05:58 -0500 )edit
0

answered 2011-12-03 05:49:56 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Volker Braun (I don't know how to call you with respect ,sorry) give the correct answer.In fact ,to install the GNOME Desktop Environment is not possible since the disk is limited,and to add space to /filesystem is a tedious job. Maybe fdisk or other tools can help you.I've tried,but failed.You can make a unix system with GUI then install sage ,with the notebook(interface=r'') command ,that works when the virtual and host pc network is NAT. That's my opinion.

edit flag offensive delete link more

Comments

You could add a 2nd disk in the virtualbox settings and shift the whole sage tree there. Make a symlink to the new location so scripts should work. Then you would have enough space to install the X system. I think this would be the quickest workaround.

Emil Widmann gravatar imageEmil Widmann ( 2011-12-03 10:03:22 -0500 )edit

The home directory is already on a separate virtual partition, Emil's suggestion won't work. I'll increase the OS partition size in the next sage release. Since it is compressed this wouldn't waste much any actual disk space as long as you are not using the additional space.

Volker Braun gravatar imageVolker Braun ( 2011-12-03 21:19:23 -0500 )edit

yep,Volker Braun's right .but I think there may be a tool that can resize the disk size. Anyway ,I don't care the " X Window System " so much.

tys gravatar imagetys ( 2011-12-04 20:09:17 -0500 )edit
0

answered 2011-10-17 11:35:40 -0500

supertat gravatar image

Thanks a lot.
I have understood the idea.
I installed gnome-desktop but startx command still can't be found.
("find / -name startx" returns no match.)

I appreciate if you could tell me how to start GNOME desktop.

edit flag offensive delete link more

Comments

I assumed that gnome-desktop would have X as a requirement, but apparently not. I've updated my answer...

Volker Braun gravatar imageVolker Braun ( 2011-10-17 23:50:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-14 15:20:19 -0500

Seen: 5,846 times

Last updated: Dec 03 '11