Ask Your Question
3

Suppressing warning messages

asked 2011-06-16 08:26:38 -0600

shacsmuggler gravatar image

When I do the following sage code, I get a warning message::

sage: R.<x,y,z> = QQbar[]
sage: poly = x^3 + y^3 + z^3
sage: mr = poly.parent().quo(poly.jacobian_ideal()); mr
Quotient of Multivariate Polynomial Ring in x, y, z over Algebraic Field by the ideal (3*x^2, 3*y^2, 3*z^2)
sage: project = mr.cover()
verbose 0 (2416: multi_polynomial_ideal.py, groebner_basis) Warning: falling back to very slow toy implementation.

This piece of code is repeated several times in a larger project, and all the warning messages are messing up the output. Is there a way to turn them off? (Yes, I do need to use QQbar, even though this example didn't use it.)

Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
3

answered 2011-06-16 10:24:47 -0600

niles gravatar image

Try

set_verbose(-1)
edit flag offensive delete link more

Comments

Thanks! That did it.

shacsmuggler gravatar imageshacsmuggler ( 2011-06-16 11:53:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-06-16 08:26:38 -0600

Seen: 466 times

Last updated: Jun 16 '11