Ask Your Question

Sage notebook with secure connection

asked 2011-05-21 14:57:44 +0200

avi9526 gravatar image

updated 2011-05-21 14:59:03 +0200

I am using next command line to run sage notebook

gnome-terminal -e "/home/avi9526/Programs/sage-4.6.2-linux-32bit-ubuntu_10.04_lts-i686-Linux-i686-Linux/sage -n port=8000 accounts=1 open_viewer=0 interface='' ulimit='-v 500000'"

but, notebook tell me that I am crazy and someone can get access to my account (really I haven't important data in sage account). If I try to run with secure=True - sage ask me for a domain name, I type it (or just think that it was it) and get no warning about insecure mode, but, also - no access to sage notebook from world or from localhost. I really need to run with secure=True ? If yes - then how to get working web interface ?

edit retag flag offensive close merge delete


Are you just trying to use it on your computer, or from outside?

kcrisman gravatar imagekcrisman ( 2011-05-21 22:33:07 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2011-05-21 22:34:20 +0200

kcrisman gravatar image

If you are just trying to run the notebook on your own computer, you should just be able to do

./sage -n

(which could be the whole thing above which you do, except the part after -n) and enjoy a web browser pop up with the notebook.

Do remember, though, that arbitrary Python code can be executed from the notebook, so nasty things can be done via an insecure notebook accessed from off line. If you're trying to set up a server, see (for instance) this wiki page in addition to the notebook documentation.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2011-05-21 14:57:44 +0200

Seen: 427 times

Last updated: May 21 '11