Ask Your Question
1

suppressing output in notebook

asked 2011-01-08 11:09:30 -0500

czsan gravatar image

How can I suppress output in notebook? In terminal mode I can write simply a semicolon after the command, but it does not work in notebooks.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2012-01-16 08:56:17 -0500

Jason gravatar image

Another thing you can do is just put the keyword "None" as the last line in the cell. Example:

1+1
None
edit flag offensive delete link more
1

answered 2011-01-08 11:42:49 -0500

Eviatar Bach gravatar image

If you have multiple lines in one cell it should not return anything. Of course, unless you invoke something which explicitly prints to the screen, such as plot or print.

edit flag offensive delete link more

Comments

....as long as the last statement is not an expression which returns an object. Ej: a = 2+2 does not produce output

pang gravatar imagepang ( 2012-01-16 23:29:02 -0500 )edit
1

answered 2011-01-10 00:10:50 -0500

czsan gravatar image

I think the best solution is hiding the expression with an assignment statement.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-01-08 11:09:30 -0500

Seen: 940 times

Last updated: Jan 16 '12