Ask Your Question
3

What is broken on this site

asked 2010-08-18 14:06:43 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Please list here anything that is broken at http://ask.sagemath.org.

UPDATE: Please post bug reports at the main askbot development site: askbot.org.

edit retag flag offensive close merge delete

Comments

hi guys, would you consider posting these issues at http://askbot.org instead? It might actually serve two good purposes - (1) new users of this forum will be more likely to post b/c "what's broken on this site" will not be the first thing they see; (2) - you will increase activity at askbot.org

Evgeny gravatar imageEvgeny ( 2010-08-20 10:08:36 -0500 )edit

that said I don't mind at all to follow this thread as I receive updates by email, just thinking that some folks may be put off from using your forum by seeing this on top of the list :). btw, I've already fixed many of the issues mentioned here.

Evgeny gravatar imageEvgeny ( 2010-08-20 10:48:15 -0500 )edit

Can the default sort order be changed to "newest"? That might help.

ccanonc gravatar imageccanonc ( 2010-08-20 14:59:43 -0500 )edit

actually you probably want "active" - that way people will see that something is going on at the site, otherwise they are less likely to post.

Evgeny gravatar imageEvgeny ( 2010-08-20 15:15:27 -0500 )edit

Presuming the backend is SQL, a "group by" clause could also help (a 2nd level of sorting). I know pure python lets you do multiple levels of sorting as well.

ccanonc gravatar imageccanonc ( 2010-08-20 15:20:21 -0500 )edit

29 answers

Sort by ยป oldest newest most voted
1

answered 2010-08-19 00:17:15 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Is "no answers" broken? So far every question on this site has at least one answer, but on the front page some are flagged as having no answers (e.g., the question about searching source for a particular algorithm) . . . is this somehow a feature instead of a bug?

edit flag offensive delete link more

Comments

Yes, that was an indirect result of the email issue. The author of askbot has written a script that will retroactively fix this, however, I can't run it until 1-2 days from now, due to a family vacation starting now.

William Stein gravatar imageWilliam Stein ( 2010-08-19 11:30:06 -0500 )edit

ah; enjoy!

niles gravatar imageniles ( 2010-08-19 16:41:57 -0500 )edit

Great, this answered a question I had, I think.

kcrisman gravatar imagekcrisman ( 2010-08-24 14:40:59 -0500 )edit
1

answered 2011-12-20 06:16:47 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have stopped getting email updates. I tried updating my subscriptions but I don't receive any emails. Is there any way this could be fixed?

edit flag offensive delete link more

Comments

I can't get email to work now either.

niles gravatar imageniles ( 2011-12-21 01:11:09 -0500 )edit
1

answered 2010-08-18 20:56:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I have used ask.sagemath.org for ten minutes and have experienced an error like the above twice: Just after having registered, I got an error. Unfortunately, I didn't keep the error message. It was something to do with relaying a request to a funny email-address, like "qu777@something". However, my registration _was_ successful and my question was posted. When I tried to edit my question (to add "Thanks, Johan"), I got an "Index out of bounds" error. I still do, so if it is of interest, I should be able to get the full error message. Regards, Johan

edit flag offensive delete link more

Comments

This was because I hadn't setup the mailserver yet. I've now setup the mailserver.

William Stein gravatar imageWilliam Stein ( 2010-08-19 11:28:15 -0500 )edit
1

answered 2010-09-01 13:16:59 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Should deleted questions be listed under "Related questions"?

edit flag offensive delete link more

Comments

don't know. should they? right now there is s no "delete forever" function, so potentially garbage posts may appear in those "related questions" what do you think?

Evgeny gravatar imageEvgeny ( 2010-09-01 13:23:21 -0500 )edit

On this page, I see links for "test question [deleted]" and "Does asking a question work? [deleted]". Maybe we should include only questions that a not-logged-in user can browse? I don't know if this is easy/efficient to do.

Mitesh Patel gravatar imageMitesh Patel ( 2010-09-01 13:32:52 -0500 )edit

oh, I get it now. Will hide them in the next version until there is a "hard delete" function in place. Thanks!

Evgeny gravatar imageEvgeny ( 2010-09-01 14:07:14 -0500 )edit
0

answered 2010-09-23 15:55:36 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

@Admins: Not sure if this is "broken", but: Why is the Q/A link from sage-support sometimes not present?

edit flag offensive delete link more
0

answered 2012-03-13 20:28:17 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Is there a way to ban users?

http://ask.sagemath.org/users/789/edi...

This guy just posted spam as answers to two questions in the last few minutes. I have edited them to mark them as spam. But I don't know of any way to stop further such answers.

edit flag offensive delete link more

Comments

The best way to deal with spam is delete the messages and mark user accounts as blocked, but not delete the accounts, that way owner of the corresponding email address will not be able to use that account. If the accounts are deleted - he can create another with the same email address and continue.

Evgeny gravatar imageEvgeny ( 2012-03-14 18:15:26 -0500 )edit

How does one block users accounts as blocked? Is there a Karma requirement?

Shashank gravatar imageShashank ( 2012-03-14 18:24:22 -0500 )edit

There is no karma way to do it, only admins or moderators can block accounts.

Evgeny gravatar imageEvgeny ( 2012-03-14 18:45:26 -0500 )edit

Oh, forgot to mention - do flag offensive messages, they will go away after 3 flags accumulate. The required number of flags is adjustable.

Evgeny gravatar imageEvgeny ( 2012-03-14 18:46:17 -0500 )edit

Yep I flagged him three times. I guess that made him go away.

Shashank gravatar imageShashank ( 2012-03-14 23:07:36 -0500 )edit
0

answered 2012-02-25 19:59:12 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Comments disappearing.

I was trying to explain something on this thread

http://ask.sagemath.org/question/1179...

and suddenly in a matter of minutes my comments won't appear on the thread. There is no error. Comments just disappear. I tried posting the comment again no luck. I tried doing the same thing using another browser just to check whether it is a browser issue but same thing happened.

edit flag offensive delete link more

Comments

I see a bunch of your comments there... it's true that sometimes the comments are folded up so that they aren't easily visible.

kcrisman gravatar imagekcrisman ( 2012-02-27 06:22:58 -0500 )edit
0

answered 2010-12-06 03:27:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

The scope argument is lost and is not in use when moving from page 1 to page N

When for example I only wish to view unanswered questions (clicking unanswered), the url is http://ask.sagemath.org/questions/?sc.... When I click the link to e.g. page 2 the url to that page is http://ask.sagemath.org/questions/?so....

Edit: Note that the answers on page 2 in my example is not only unanswered questions - indicating that if the scope variable is stored in session it doesn't work. If I manually edit the url to go to http://ask.sagemath.org/questions/?sc...&page=2 the scope is used and works correctly.

Moreover, the questions listed on page 2 are not sorted by number of answers. Note, for example, that the question find-f2py_f2cmap-file-from-notebook shows up on page 2, even though all the unanswered questions are listed on page 1.

edit flag offensive delete link more

Comments

That's right, it is not a bug actually. The argument is actually saved in your search state, which is maintained in the session. Speaking in the technical terms the search feature is not RESTful, which means that the url is not the storage of the state here.

Evgeny gravatar imageEvgeny ( 2010-12-06 07:02:21 -0500 )edit

I've updated my 'answer', with info why it doesn't work as a session var as well. And I wonder why scope is in the url if it's actually stored in session. And why use a session var in this case?

mandrake gravatar imagemandrake ( 2010-12-06 19:45:24 -0500 )edit

What is odd is that if I copy-paste the the first two urls you gave into the new browser window, everything works just fine. The same happens if I click "unanswered" and then "page 2". Maybe somehow whatever is in your search state became inconsistent. Try deleting the cookie - will that help? Did you modify the url manually? Perhaps it is better to use stateless approach and keep everything in the url, but it will take some work. Search state includes: text query, scope, sort order, page number, tag selection and user (the latter is not yet easily accessible). For all that to work in the url, the parameters need to be appended to every relevant link in the main page and updated in any ajax calls, but maybe I'll just get it done. In addition there are ignored tags, stored separately.

Evgeny gravatar imageEvgeny ( 2010-12-06 20:41:03 -0500 )edit

the question is whether it is worth making search restful or it will be better to just fix the state storage. BTW - feel free to fork askbot on github and improve something.

Evgeny gravatar imageEvgeny ( 2010-12-06 21:13:46 -0500 )edit

I tried repeating the steps in IE (my clean browser since I never use it) and it was repeatable. I.e. clicking unanswered and then page two lost the search state. I also tried copy pasting the link in IE and it worked after that! That's kind of wierd :)

mandrake gravatar imagemandrake ( 2010-12-06 22:22:41 -0500 )edit
0

answered 2010-08-19 05:31:43 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

There is some kind of syntax error in the question "File imports for polynomial rings in sage". Maybe it's user error, but it might be the kind of user error that's prone to happen a lot when there are angle brackets flying around.

edit flag offensive delete link more

Comments

There are a whole bunch of questions affected by the mail server issue. I'll try to see what can be done through the django admin interface...

Evgeny gravatar imageEvgeny ( 2010-08-19 09:47:45 -0500 )edit

Even though the mailserver is configured, the corrupted questions are still in the database.

Evgeny gravatar imageEvgeny ( 2010-08-19 09:48:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

5 followers

Stats

Asked: 2010-08-18 14:06:43 -0500

Seen: 2,106 times

Last updated: Jul 19 '16