Ask Your Question
1

How to deal with "GAPError: Error, reached the pre-set memory limit" ?

asked 2022-04-05 03:12:25 +0200

Max Alekseyev gravatar image

updated 2022-04-05 06:29:11 +0200

I get the following error while doing group theoretic computations in Sage:

GAPError: Error, reached the pre-set memory limit
(change it with the -o command line option)

How overcome it by allowing GAP use more memory? Where exactly I should use -o option?


Here is a code producing an error:

def a138077_q(q): G = PSL(3, q); d = G.order(); return d // max(H.order() for H in G.conjugacy_classes_subgroups() if H.order()<d)
print(a138077_q(13))
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2022-04-05 06:35:01 +0200

Max Alekseyev gravatar image

updated 2022-04-06 21:48:18 +0200

A solution at this link suggests that -o should be added to sage.interfaces.gap.gap_cmd variable like

sage.interfaces.gap.gap_cmd = 'gap -r -o 4G '

For my problem, increase to 64G produced GAPError: Error, the perfect residuum is too large, but that's a different story.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-04-05 03:12:25 +0200

Seen: 82 times

Last updated: Apr 06