Ask Your Question
1

SPKGs did not find equivalent system packages 9.4 WSL2

asked 2021-11-23 08:24:12 +0100

ortollj gravatar image

updated 2021-11-23 10:53:40 +0100

Hi

Trying to install 9.4 in WSL with sage-9.4-Ubuntu_20.04-x86_64.tar.bz2 :

Install Sage Math from source on WSL

I got this message at the step 4) Start building :

config.status: creating directory local/var/lib/sage/installed
configure:

    notice: the following SPKGs did not find equivalent system packages:

        arb cddlib ecl eclib flint fplll gc giac lcalc libhomfly pari pari_galdata pari_seadata_small   _recommended coxeter3 gp2c igraph libsemigroups lrslib pari_elldata pari_galpol pari_nftables pari_seadata

checking for the package system in use... debian
configure:

    hint: installing the following system packages, if not
    already present, is recommended and may avoid having to
    build them (though some may have to be built anyway):

      $ sudo apt-get update
      $ sudo apt-get install  libflint-arb-dev libcdd-dev libcdd-tools ecl libec-dev eclib-tools libflint-dev libgc-dev libgiac-dev xcas lcalc liblfunction-dev libhomfly-dev pari-gp2c libpari-dev pari-doc pari-elldata pari-galdata pari-galpol pari-seadata

configure:

    hint: installing the following system packages, if not
    already present, may provide additional optional features:

      $ sudo apt-get update
      $ sudo apt-get install  texlive-latex-extra texlive-xetex latexmk dvipng default-jdk ffmpeg libavdevice-dev pari-gp2c libigraph-dev lrslib

configure:

    hint: After installation, re-run configure using:

      $ ./config.status --recheck && ./config.status

ortollj@DESKTOP-K30FLRP:~/sage-9.4$ sudo apt-get install  libflint-arb-dev libcdd-dev libcdd-tools ecl libec-dev eclib-tools libflint-dev libgc-dev libgiac-dev xcas lcalc liblfunction-dev libhomfly-dev pari-gp2c libpari-dev pari-doc pari-elldata pari-galdata pari-galpol pari-seadata
[sudo] password for ortollj:
Reading package lists... Done
Building dependency tree
Reading state information... Done
libgc-dev is already the newest version (1:7.6.4-0.4ubuntu1).
ecl is already the newest version (16.1.3+ds-4).
eclib-tools is already the newest version (20190909-2build2).
lcalc is already the newest version (1.23+dfsg-11build1).
libcdd-dev is already the newest version (094j-2).
libcdd-tools is already the newest version (094j-2).
libec-dev is already the newest version (20190909-2build2).
libflint-arb-dev is already the newest version (1:2.17.0-1).
libflint-dev is already the newest version (2.5.2-21build1).
libgiac-dev is already the newest version (1.5.0.85+dfsg1-3).
libhomfly-dev is already the newest version (1.02r5-1).
liblfunction-dev is already the newest version (1.23+dfsg-11build1).
libpari-dev is already the newest version (2.11.2-2).
pari-doc is already the newest version (2.11.2-2).
pari-elldata is already the newest version (0.20190911-1).
pari-galdata is already the newest version (0.20080411-2).
pari-galpol is already the newest version (4.0-1).
pari-gp2c is already the newest version (0.0.11pl2-3).
pari-seadata is already the newest version (0.20090618-1).
xcas is already the newest version (1.5.0.85+dfsg1-3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ortollj@DESKTOP-K30FLRP:~/sage-9.4$ sudo apt-get install  texlive-latex-extra texlive-xetex latexmk dvipng default-jdk ffmpeg libavdevice-dev pari-gp2c libigraph-dev lrslib
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libigraph0-dev' instead of 'libigraph-dev'
default-jdk is already the newest version (2:1.11-72).
dvipng is already the newest version (1.15-1.1).
latexmk is already the newest version (1:4.67-0.1).
libigraph0-dev is already the newest version (0.7.1-4build1).
lrslib is already the newest version (0.70-3).
pari-gp2c is already the newest version (0.0.11pl2-3).
texlive-latex-extra is already the newest version (2019.202000218-1).
texlive-xetex is already the newest version (2019.20200218-1).
ffmpeg is already the newest version (7:4.2.4-1ubuntu0.1).
libavdevice-dev is already the newest version (7:4.2.4-1ubuntu0.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
edit retag flag offensive close merge delete

Comments

Note that my previous installation of 9.2 in WSL was successfull

my WSL linux Version :

ortollj@DESKTOP-K30FLRP:~/sage-9.4$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.3 LTS
Release:        20.04
Codename:       focal

I tried this:

ortollj@DESKTOP-K30FLRP:~/sage-9.4$ sudo apt-get install -y libcdd-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
libcdd-dev is already the newest version (094j-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
ortollj@DESKTOP-K30FLRP:~/sage-9.4$
ortollj gravatar imageortollj ( 2021-11-23 08:32:44 +0100 )edit

I edited the title and add a 2 at WSL, i used WSL2.

ortollj gravatar imageortollj ( 2021-11-23 10:56:22 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2021-11-23 10:25:46 +0100

eric_g gravatar image

The configure messages are just recommendations. If the equivalent system packages are not found or are not usable by Sage due to some version mismatch, they will be locally installed by Sage. So you can safely proceed with the installation by typing make.

edit flag offensive delete link more

Comments

thank you @eric_g

I will continue the installation (should take a while), and I tell you if all is ok in few half hours.

ortollj gravatar imageortollj ( 2021-11-23 10:47:29 +0100 )edit

its ok ;-)

make[2]: Leaving directory '/home/ortollj/sage-9.4/build/make'

real    121m6.280s
user    125m19.529s
sys     5m58.136s
Sage build/upgrade complete!
make[1]: Leaving directory '/home/ortollj/sage-9.4'
ortollj@DESKTOP-K30FLRP:~/sage-9.4$

┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 9.4, Release Date: 2021-08-22                     │
│ Using Python 3.8.10. Type "help()" for help.                       │
└────────────────────────────────────────────────────────────────────┘
sage:

the make process lasted 2 hours

ortollj gravatar imageortollj ( 2021-11-23 12:41:21 +0100 )edit

Now all is ok when I click on my desktop icon sageJupyterLab SageMath9.4 Jupyter Lab is launched ;-) I just encountered a little pb with edit but its ok if I use nano in place of edit

ortollj@DESKTOP-K30FLRP:~$ edit sage_nb.sh
Error: no "edit" mailcap rules found for type "application/x-sh"
ortollj@DESKTOP-K30FLRP:~$ nano sage_nb.sh
ortollj gravatar imageortollj ( 2021-11-23 13:57:11 +0100 )edit
1

If you have 4 cores on your CPU, you can speed up the installation by typing

MAKE="make -j8" make

instead of make. The flag -j8 tells to use 8 threads in parallel. Adapt to your CPU (typically use a number of threads that is twice the number of cores).

eric_g gravatar imageeric_g ( 2021-11-23 13:57:14 +0100 )edit
1

If you want less noise:

MAKE='make -j8' make -s V=0
slelievre gravatar imageslelievre ( 2021-11-23 14:15:24 +0100 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-11-23 08:24:12 +0100

Seen: 48 times

Last updated: Nov 23