Sage Notebook IOPub data rate exceeded error?

asked 2019-01-08 00:05:21 -0500

Stockfish3709 gravatar image

updated 2019-01-08 00:06:00 -0500

Hi,

Currently I'm running a very system intensive process on Sage and I'm getting this error.

IOPub data rate exceeded.
The notebook server will temporarily stop sending output
to the client in order to avoid crashing it.
To change this limit, set the config variable
`--NotebookApp.iopub_data_rate_limit`.

Current values:
NotebookApp.iopub_data_rate_limit=1000000.0 (bytes/sec)
NotebookApp.rate_limit_window=3.0 (secs)

From research, I am supposed to paste the below in my command prompt.

jupyter notebook --generate-config

But when I try to do so, it says that it is not recognised as an internal or external command.

How do I resolve this issue?

edit retag flag offensive close merge delete

Comments

You should check that the documentation your research has led you to is applicable to Sage's jupyter and jupyter modules' version : Sage is not up to date on ths respect (and won't until the port to Python 3 is complete : recent jupyter versions need Python 3).

Emmanuel Charpentier gravatar imageEmmanuel Charpentier ( 2019-01-08 01:18:02 -0500 )edit

Jupyter has been updated to version 5.7.1 in SageMath 8.5, which has been released on 20 December. Maybe it is worth to try with SageMath 8.5 if you have not already done it.

eric_g gravatar imageeric_g ( 2019-01-08 08:07:36 -0500 )edit