Ask Your Question

viewer 3D problem

asked 2018-04-08 20:17:24 +0200

danielvolinski gravatar image

I'm using SageMath 8.1 on Windows 10 Native with Jupyter Notebook.

The only 3D viewer that works is tachyon.

Both threejs and jmol leave an empty space without plot but no error is issued, all this for the same 3D plot tachyon was able to plot.

edit retag flag offensive close merge delete


FWIW this is basically a duplicate of

Iguananaut gravatar imageIguananaut ( 2018-04-09 15:51:40 +0200 )edit

It is related: at that time I didn't know it is a general issue, I thought the problem was related to vector fields only.

danielvolinski gravatar imagedanielvolinski ( 2018-04-09 16:42:39 +0200 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-04-08 21:29:35 +0200

eric_g gravatar image

updated 2018-04-08 21:55:04 +0200

A recent fix regarding Jmol with Windows has just been merged in Sage 8.2.rc1: #25021. Maybe this will solve your issue in Sage 8.2 (to be released soon).

Regarding the threejs issue, are you using the argument online=True along with viewer='threejs'? If yes, can you try with online=False?

edit flag offensive delete link more


I'm not using online=True

As per your suggestion I tried:

sage: sphere = surfaces.Sphere(center=(0, 1, -1), R=2); sphere
sage: sphere.plot(viewer='threejs', online=False)

It doesn't matter if I put online=False or online=True, I always get an empty space using threejs.


danielvolinski gravatar imagedanielvolinski ( 2018-04-09 00:53:27 +0200 )edit

What about sphere.plot().show(viewer='threejs')?

slelievre gravatar imageslelievre ( 2018-04-09 01:57:15 +0200 )edit

@danielvolinski: given your answer, let me reverse my question: does it help to use online=True? (note: online=False is the default).

eric_g gravatar imageeric_g ( 2018-04-09 09:14:06 +0200 )edit

sage: sphere.plot().show(viewer='threejs') gives an empty space.

sage: sphere.plot(viewer='threejs', online=False) gives an empty space.

sage: sphere.plot(viewer='threejs', online=True) gives an empty space.


danielvolinski gravatar imagedanielvolinski ( 2018-04-09 16:38:56 +0200 )edit

I created a ticket for this issue along with a fix: It really should work with online=True unless of course you don't actually have an internet connection. Depending on the speed of your connection it might take a few seconds for the scripts to download--you can also try refreshing. Otherwise open your browser's developer console and see if there are any informative errors...

Iguananaut gravatar imageIguananaut ( 2018-04-09 17:10:13 +0200 )edit

answered 2018-04-09 10:40:03 +0200

Iguananaut gravatar image

The threejs viewer should work with online=True. It does not work with online=False due to a known path issue that I just haven't fixed yet.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2018-04-08 20:17:24 +0200

Seen: 1,436 times

Last updated: Apr 08 '18