Ask Your Question
1

Upgrading GAP in SAGE

asked 2017-10-26 22:11:49 -0600

Vincent Russo gravatar image

Hello,

I'm attempting to upgrade the version of GAP that is used in SAGE. I installed the most recent version of GAP 4.8.8. When I open SAGE and run

gap.version()
4.8.3

I know I can point the GAP console in SAGE to the 4.8.8 version of GAP by running:

import sage.interfaces.gap
GAP_PATH = "/home/captainhampton/gap4r8/bin/gap.sh"
sage.interfaces.gap.gap_cmd = GAP_PATH

which is where I've installed the 4.8.8 version of GAP. Indeed, if I run

gap.console()
 ┌───────┐   GAP 4.8.8, 20-Aug-2017, build of 2017-10-12 22:05:03 (EDT)
 │  GAP  │   
 └───────┘   Architecture: x86_64-pc-linux-gnu-gcc-default64
 Libs used:  gmp, readline
 Loading the library and packages ...
 Components: trans 1.0, prim 2.1, small* 1.0, id* 1.0
 Packages:   AClib 1.2, Alnuth 3.0.0, AtlasRep 1.5.1, AutPGrp 1.8, Browse 1.8.7, CRISP 1.4.4, Cryst 4.1.12, CrystCat 1.1.6, CTblLib 1.2.2, FactInt 1.5.4, FGA 1.3.1, GAPDoc 1.6, 
             IO 4.4.6, IRREDSOL 1.4, LAGUNA 3.7.0, Polenta 1.3.7, Polycyclic 2.11, RadiRoot 2.7, ResClasses 4.6.0, Sophus 1.23, SpinSym 1.5, TomLib 1.2.6, Utils 0.46
 Try '??help' for help. See also '?copyright', '?cite' and '?authors'

However, if in SAGE, this does not change gap.version(). It still gives 4.8.3. Is there a way I can point this gap to the 4.8.8 version? Thanks.

edit retag flag offensive close merge delete

Comments

This would require you mucking with the code that gives the gap version in Sage, which may be hardcoded in the pkg. But clearly it is running correctly otherwise.

kcrisman gravatar imagekcrisman ( 2017-10-27 11:39:06 -0600 )edit

Right, but unfortunately I require the use of GAP 4.8.8 instead of 4.8.3 due to KBMAG package. So being able to update GAP in SAGE would be really really helpful to me.

Vincent Russo gravatar imageVincent Russo ( 2017-10-27 14:27:09 -0600 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2017-10-28 09:00:16 -0600

tmonteil gravatar image

If this can help:

  • the current Sage ships 4.8.6, not 4.8.3, so perhaps should you upgrade your Sage install and check if it works,
  • kbmag claims to be able to run on >= 4.7 gap versions.
edit flag offensive delete link more

Comments

That'll do the trick. Thanks!

Vincent Russo gravatar imageVincent Russo ( 2017-10-31 16:48:37 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-10-26 22:11:49 -0600

Seen: 48 times

Last updated: Oct 28