Cannot get Maxima to run in terminal in OS10.11.6

asked 2017-01-09 19:00:21 -0600

Pasta gravatar image

updated 2017-01-10 15:18:49 -0600

FrédéricC gravatar image

I downloaded Sage-math-7.4.app for MacOSX (running El Capitan on 2016 Mac Book). Double clicked SageMath-7.4.app. I selected Terminal Session>Math>maxima . A terminal window appears with the following text:

Last login: Mon Jan 9 19:09:51 on ttys001 /Users/unlmath/Desktop/SAGE/SageMath-7.4.app/Contents/Resources/sage/sage --maxima; exit MacBook-Pro:~ unlmath$ /Users/unlmath/Desktop/SAGE/SageMath-7.4.app/Contents/Resources/sage/sage --maxima; exit ;;; Loading #P"/Users/unlmath/Desktop/SAGE/SageMath-7.4.app/Contents/Resources/sage/local/lib/ecl/sb-bsd-sockets.fas" ;;; Loading #P"/Users/unlmath/Desktop/SAGE/SageMath-7.4.app/Contents/Resources/sage/local/lib/ecl/sockets.fas"

Condition of type: END-OF-FILE Unexpected end of file on #<sequence-input stream="" 000000010b9691e0="">. No restarts available.

Top level.
>

As far as I can tell Maxima is not running. I'm not sure what is running at the ">" prompt. I haven't found anything on-line describing this problem. If I select Terminal Session>Math>gap it runs gap in the terminal, and if I select Terminal Session>sage it runs sage. Maxima behaves differently. I'd like to get it working.

edit retag flag offensive close merge delete

Comments

What happens if you select Terminal Session > sage and then type maxima_console()? Or if you just ask for a terminal session with no system and then type sage -maxima? Those are alternate ways to get this.

kcrisman gravatar imagekcrisman ( 2017-01-09 20:23:48 -0600 )edit

Also, if you try to integrate (say, x^2) does that work? (This uses Maxima internally.)

kcrisman gravatar imagekcrisman ( 2017-01-09 20:24:08 -0600 )edit

Thanks for the suggestions. I downloaded Maxima separately and can run it on its own, but it's as if it's not included in the sage package. None of maxima_console(), sage -maxima or just integrating x^2 work. I can't show you what happens since that exceeds the maximum comment length allowed here. Maybe I'll try downloading a different version of the sage package.

Pasta gravatar imagePasta ( 2017-01-11 09:03:03 -0600 )edit

Wow, that is bad (and unusual). Almost certainly something was compiled for a different version of Mac than you have, though there could be some other error. If you are familiar with the command line just a little, it actually wouldn't be too hard for you to compile from scratch (though it would take a few hours!).

kcrisman gravatar imagekcrisman ( 2017-01-11 16:28:45 -0600 )edit