Ask Your Question
1

start sage

asked 2016-07-11 12:55:16 -0600

jkid314159 gravatar image

System: #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08)

type in from command line "sage" error says, "bash: sage: command not found" How can I start sage. Thanks.

edit retag flag offensive close merge delete

Comments

How did you install Sage ?

tmonteil gravatar imagetmonteil ( 2016-07-11 16:01:31 -0600 )edit

Have you tried to type ./sage (from the sage root directory), instead of sage ?

eric_g gravatar imageeric_g ( 2016-07-11 16:33:33 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-07-12 07:43:19 -0600

slelievre gravatar image

Installing Sage just installs Sage, it does not automatically make the sage command point to Sage.

So either change directory to where sage is installed and run ./sage as @eric_g suggests, or take one of the following steps.

  • use an alias by adding this line in your .bashrc or .bash_profile settings file:

    alias sage='/path/to/sage'
    
  • or add a symbolic link in a place that is in your PATH, say /usr/local/bin, by running the command

    $ sudo ln -s /path/to/sage /usr/local/bin
    

(you would replace /path/to/sage by the actual path to the sage executable you have installed).

A related trick: GAP, Singular, etc., are bundled with Sage. There is a command to create creating symbolic links for all of them in a chosen directory. To create the symbolic links in /usr/local/bin, run this command:

$ sudo sage -c "install_scripts('/usr/local/bin')
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-07-11 12:55:16 -0600

Seen: 97 times

Last updated: Jul 12 '16