Ask Your Question
2

Sage Notebook and NoScript

asked 2016-05-06 23:49:40 +0200

anja gravatar image

I am using NoScript 2.6.9.15 in Firefox 38.0.1 on Fedora 21. When I tried to use Sage Notebook 7.1, I was asked by NoScript to allow scripts on localhost. I did but the Notebook did not work until I allowed all scripts.

Does somebody know why this happens?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2016-05-10 19:29:57 +0200

tmonteil gravatar image

updated 2016-05-10 19:33:54 +0200

There is indeed something weird here. Unfortunately it works for me with Iceweasel version 38.7.1 and xul-ext-noscript package on Debian stable.

I tried to allow localhost by going to "options" then "white list", then adding "localhost" and it worked as well. If is it not enough, you could try to add "localhost:8080" to specify the (nonstandard) port.

edit flag offensive delete link more

Comments

Thank you for the easy solution, Thierry. I added "localhost" to the white list manually and now it works.

I removed localhost from the white list to see what is the difference. In fact, NoScript asks to allow "http://localhost" but now it worked and I couldn't reproduce the problem.

anja gravatar imageanja ( 2016-05-19 21:00:28 +0200 )edit
0

answered 2016-05-10 16:21:58 +0200

kcrisman gravatar image

I'm not that familiar with NoScript but if it really blocks a heck of a lot of JS, then one would expect the notebook not to work well, as a largely javascript application! We often have problems with it not working when one JS component is upgraded, e.g. jQuery, until one does a hard cache reset. So this is not a surprise, I guess?

edit flag offensive delete link more

Comments

I guess the issue is not a bout blocking javascript, but about allowing it on localhost being not sufficient.

tmonteil gravatar imagetmonteil ( 2016-05-10 19:30:57 +0200 )edit

Right. When I asked the question, allowing localhost wasn't sufficient to use the Notebook. Now, I couldn't reproduce the problem (see comment on accepted answer).

anja gravatar imageanja ( 2016-05-19 21:02:43 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-05-06 23:49:40 +0200

Seen: 105 times

Last updated: May 10 '16