Ask Your Question
0

output.txt not updated

asked 2015-12-15 06:20:55 -0500

Erel Segal-Halevi gravatar image

I made some calculations in the SageMath notebook and got a message "WARNING: Output truncated! " with a link to "full_output.txt".

Then, I made some changes and ran the same calculation again. I got a similar message, but when I clicked the link, I saw the old full_output.txt file - without my changes.

How can I tell SageMath notebook to stop caching the file and create a fresh file?

edit retag flag offensive close merge delete

Comments

If full_output.txt is used to get info from Sage on a regular basic then I would suggest considering some sharing technology. The particular type of sharing software would depend on where is your sage server is installed. See for example: Sage Appliance and sharing-files-between-sage-and-windows. Alternatively you can install additional software to expose a part of server's file system: * Use Apache or ngix with automatic indexing to target a particular directory; and then you would only need to write your file to that shared directory. * Use NFS/SMB * Use sshfs

Eugene gravatar imageEugene ( 2015-12-15 13:20:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-12-15 08:02:52 -0500

kcrisman gravatar image

This is https://github.com/sagemath/sagenb/is... . Note that

This has usually been considered a browser "feature" and not a Sage/sagenb issue

so it may not be 'fixed' very soon, if ever. But reloading should get you what you want.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-15 06:20:55 -0500

Seen: 179 times

Last updated: Dec 15 '15