Ask Your Question
0

Problems to start sage -notebook=ipython

asked 2015-10-18 10:04:56 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

With Sagemath version 6.6 the command "sage -notebook = ipython" worked fine.

I upgraded to the 6.8 version and every time I try the same command, I get the following message:

The IPython notebook requires ssl, even if you do not use https. Install the openssl development packages in your system and then rebuild Python (sage -f python).

Does anyone know the correct way workaround this?

edit retag flag offensive close merge delete

Comments

1

This might depend on the OS you use. What operating system are you using?

Eg. if you are using Debian based OS (eg *buntu) you may try installing libssl-dev, or if you are using a Red Hat based OS you can try openssl-devel.

fidbc gravatar imagefidbc ( 2015-10-18 13:05:35 -0600 )edit

Got the same problem here. The problem is that the version installed by ubuntu is libssl-dev (with libssl version 1.0.0) and Ipython wants a more recent one.

vdelecroix gravatar imagevdelecroix ( 2016-01-22 09:28:20 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-01-22 09:34:34 -0600

Hello,

One solution is to install openssl Sage package with

$ sage -p openssl

Then it should work

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-10-18 10:04:56 -0600

Seen: 804 times

Last updated: Jan 22 '16