Ask Your Question

setwd() function in R does not work in Sage

asked 2015-06-27 18:02:11 -0600

NahsiN gravatar image

Hello, I am trying to use setwd() for R in the sage notebook to set the current working directory. But it does not seem to work. I get the following

[1] "/tmp/tmpR8Ukt0"

So as shown, the setwd() command has no effect. Any suggestions?

edit retag flag offensive close merge delete


Is it all in the same cell? That's the only way I could imagine this working, as sagenb (by design) uses temp directories to actually evaluate each cell.

kcrisman gravatar imagekcrisman ( 2015-06-27 22:30:49 -0600 )edit

No they were in separate cells. Putting the two commands in one cell works. Thanks for the clarification. Now it makes sense.

NahsiN gravatar imageNahsiN ( 2015-07-16 17:00:28 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2015-07-25 08:05:26 -0600

kcrisman gravatar image

See comments: this would only work in the same cell.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-06-27 18:02:11 -0600

Seen: 458 times

Last updated: Jul 25 '15