Ask Your Question
1

qepcad failing to replicate examples

asked 2015-05-08 19:08:34 -0600

MickleMouse gravatar image

updated 2015-10-31 05:28:32 -0600

tmonteil gravatar image

I was attempting to replicate the examples seen here (http://www.sagemath.org/doc/reference...), but I keep getting errors.

Given ︠482004e5-daf3-4312-b5d7-a61b41d210a4s︠ var('a,b,c,d,x,y,z') qf = qepcad_formula;

ellipse = 3x^2 + 2x*y + y^2 - x + y - 7 F = qf.exists(y, ellipse == 0); F qepcad(F)

︡202e02ca-ac90-4b34-afab-7d6ceb6d41f5︡{"stdout":"(a, b, c, d, x, y, z)\n"}︡{"stdout":"(E y)[3 x^2 + 2 x y + y^2 - x + y - 7 = 0]\n"}︡{"stderr":"Error in lines 5-5\n"}︡{"stderr":"Traceback (most recent call last):\n File \"/projects/45572f4b-6bd1-49bd-9d46-5f340788b465/.sagemathcloud/sage_server.py\", line 879, in execute\n exec compile(block+'\n', '', 'single') in namespace, locals\n File \"\", line 1, in <module>\n File \"/usr/local/sage/sage-6.5/local/lib/python2.7/site-packages/sage/interfaces/qepcad.py\", line 1431, in qepcad\n qe = Qepcad(formula, vars=vars, **kwargs)\n File \"/usr/local/sage/sage-6.5/local/lib/python2.7/site-packages/sage/interfaces/qepcad.py\", line 777, in __init__\n qex._send('[ input from Sage ]')\n File \"/usr/local/sage/sage-6.5/local/lib/python2.7/site-packages/sage/interfaces/expect.py\", line 212, in _send\n self._start()\n File \"/usr/local/sage/sage-6.5/local/lib/python2.7/site-packages/sage/interfaces/expect.py\", line 445, in _start\n raise RuntimeError(\"unable to start %s\" % self.name())\nRuntimeError: unable to start QEPCAD\n"}︡ ︠5c912bc8-cd8b-495c-9fa3-eda33c34530e︠

edit retag flag offensive close merge delete

Comments

Seems cut-and paste went slightly wrong. To display lines of code, select them and click the 'code' button (the one with '010 101'). Try editing your question and doing that.

slelievre gravatar imageslelievre ( 2015-05-10 08:10:31 -0600 )edit

Can we mark this question as outdated? qepcad installs just fine, and I can think of no reason why anyone would want to read it now.

pang gravatar imagepang ( 2016-05-12 08:22:08 -0600 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2015-05-09 03:11:05 -0600

tmonteil gravatar image

updated 2015-10-31 05:31:53 -0600

This is because QEPCAD is an experimental package, see this page. So you will have to install it first. The way to install it is to type, from a terminal:

sage -i qepcad

Note that since qemcad is an experimental, and looking at trac tickets 16642 and 10224, it is very unlikely that you will succeed to install it (i did not succeed myself).

EDIT I am happy to say that qepcad has been repackaged so that 10224 is fixed and you should be able to install it now.

edit flag offensive delete link more

Comments

qepcad did install here on 6.10.p1 after I set my MAKE to make -j1.

rws gravatar imagerws ( 2015-10-24 09:24:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-08 19:08:34 -0600

Seen: 330 times

Last updated: Oct 31 '15