Ask Your Question
0

linbox error in sage 6.4 install to ubuntu 14.04

asked 2015-01-18 04:40:08 -0600

Kevin Smith gravatar image

updated 2015-01-18 08:48:07 -0600

I have just switched over to ubuntu and attempted to install sagemath for the first time. The install ran for about an hour then stopped with the following information in the logfile:

make[7]: Entering directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src/linbox/util'
/bin/bash ../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../linbox -I/home/kevin/Downloads/sage/local/include -I/home/kevin/Downloads/sage/local/include -DDISABLE_COMMENTATOR -O2    -g -DNDEBUG -U_LB_DEBUG -I/home/kevin/Downloads/sage/local/include  -g -fPIC -c -o error.lo error.C
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../../linbox -I/home/kevin/Downloads/sage/local/include -I/home/kevin/Downloads/sage/local/include -DDISABLE_COMMENTATOR -O2 -g -DNDEBUG -U_LB_DEBUG -I/home/kevin/Downloads/sage/local/include -g -fPIC -c error.C  -fPIC -DPIC -o .libs/error.o
/bin/bash ../../libtool --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I. -I../..  -I../.. -I../../linbox -I/home/kevin/Downloads/sage/local/include -I/home/kevin/Downloads/sage/local/include -DDISABLE_COMMENTATOR -O2    -g -DNDEBUG -U_LB_DEBUG -I/home/kevin/Downloads/sage/local/include  -g -fPIC -c -o debug.lo debug.C
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../../linbox -I/home/kevin/Downloads/sage/local/include -I/home/kevin/Downloads/sage/local/include -DDISABLE_COMMENTATOR -O2 -g -DNDEBUG -U_LB_DEBUG -I/home/kevin/Downloads/sage/local/include -g -fPIC -c debug.C  -fPIC -DPIC -o .libs/debug.o
/bin/bash ../../libtool --tag=CXX   --mode=link g++ -O2    -g -DNDEBUG -U_LB_DEBUG -I/home/kevin/Downloads/sage/local/include  -g -fPIC -L/home/kevin/Downloads/sage/local/lib -lgivaro    -o libutil.la  error.lo debug.lo  -L/home/kevin/Downloads/sage/local/lib -lgivaro
libtool: link: warning: library `/home/kevin/Downloads/sage/local/lib/libgivaro.la' was moved.
/bin/grep: /home/buildslave-sage/slave/sage_git/build/local/lib/libgmpxx.la: No such file or directory
/bin/sed: can't read /home/buildslave-sage/slave/sage_git/build/local/lib/libgmpxx.la: No such file or directory
libtool: link: `/home/buildslave-sage/slave/sage_git/build/local/lib/libgmpxx.la' is not a valid libtool archive
make[7]: *** [libutil.la] Error 1
make[7]: Leaving directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src/linbox/util'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src/linbox/util'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src/linbox'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/kevin/Downloads/sage/local/var/tmp/sage/build/linbox-1.3.2.p1/src'
Error building LinBox.

This is well over my head, so I wonder if anyone can help-there doesn't seem to be anything on the ubuntu forums.

Thanks in advance

edit retag flag offensive close merge delete

Comments

Have you checked the dependencies ?

Linux: gcc, make, m4, perl, ranlib, and tar. (install these using your package manager) On recent Debian or Ubuntu systems (in particular Ubuntu 12.04 "Precise"), you need the dpkg-dev package.

FrédéricC gravatar imageFrédéricC ( 2015-01-18 05:07:50 -0600 )edit

I have all of those yes.

Kevin Smith gravatar imageKevin Smith ( 2015-01-18 05:37:50 -0600 )edit

Could you please give more details on how you went there ? For example, where did you get the tarball ? Which command did you type precisely ? The reference to /home/buildslave-sage/ looks very weird.

tmonteil gravatar imagetmonteil ( 2015-01-18 14:01:32 -0600 )edit

In particular, it would imply you downloaded a binary but tried to (re)build it from scratch. Maybe you should just download the source.

kcrisman gravatar imagekcrisman ( 2015-01-18 19:19:14 -0600 )edit

I downloaded the .lzma tarball of the source files from the linux site, into home/Downloads. I used the archive manager to unzip it,I renamed the file unzipped file SAGE_ROOT and put it into the home directory. I then typed 'make' in home/SAGE_ROOT.

I think somehow I've managed to recreate a problem involving the DDISABLE_COMMENTATOR business that one finds people encountered on mac OS, not sure.

It appears

Kevin Smith gravatar imageKevin Smith ( 2015-01-19 13:37:08 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2015-01-19 01:33:01 -0600

To install on Ubuntu you have several options, see Sage's Linux download page:

  • install a binary (pick a mirror on the Linux download page and choose the correct binary for your system).

  • use the Ubuntu PPA by team AIMS.

    Ubuntu PPA

    There is also a PPA for Ubuntu available. Install Sage this way:

    apt-add-repository -y ppa:aims/sagemath
    apt-get update
    apt-get install sagemath-upstream-binary
    
  • build from source. For that, download the source tarball from Sage's source download page, expand it, and run make.

edit flag offensive delete link more

Comments

Thank you for this useful answer.

Kevin Smith gravatar imageKevin Smith ( 2015-01-19 14:20:09 -0600 )edit

What if I have a 32-bit machine? I cannot use the ppa above! Have the same issue on Ubuntu 14.04.

Grigory gravatar imageGrigory ( 2015-02-24 16:19:15 -0600 )edit

Thierry Monteil is working on producing PPAs for many versions of Ubuntu and Debian. See https://groups.google.com/d/msg/sage-... .

slelievre gravatar imageslelievre ( 2015-03-01 06:12:44 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-01-18 04:40:08 -0600

Seen: 333 times

Last updated: Jan 19 '15