Ask Your Question
2

no method available for opening http localhost 8000 (second part)

asked 2014-12-11 10:35:46 -0500

emiliocba gravatar image

I have exactly the same problem as in this question. It has an answer with two solutions:

  • install a web browser inside the VM,
  • punch port 8000 through to the host and use the host web browser.

I want to use the second option but I cannot understand it. Could somebody explain in detail the second option?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-12-13 07:23:29 -0500

updated 2014-12-13 16:06:39 -0500

I suppose this is described in Sect 6.3.1 of https://www.virtualbox.org/manual/Use...

Sage notebook runs a webserver that is to be accessed on port 8000 (and this happens inside VM, on "guest OS"). You need a setting that maps this port to a port X (X need not be equal to 8000) on the "host OS"; then you can access the Sage notebook from the "host OS" by pointing its web browser to http://localhost:X

edit flag offensive delete link more

Comments

(Is it 8080 now?)

kcrisman gravatar imagekcrisman ( 2014-12-13 17:39:56 -0500 )edit

probably - although perhaps the VM Sage image has it differently. One can see the port number if you start sage in terminal and do 'notebook()' at sage prompt. It will tell you which URL to open in browser.

Dima gravatar imageDima ( 2014-12-13 19:41:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-11 10:35:46 -0500

Seen: 515 times

Last updated: Dec 13 '14