Ask Your Question
0

sage-6.4.1 modification notebook order in shell mode

asked 2014-12-03 04:13:39 -0500

rafarob gravatar image

With sage-6.3 I can execute in linux from terminal mode: sage -notebook "/home/user_name/directory_that_contains_the_Sage_notebook_files.sagenb" but with sage-6.4.1 I can't I need to create a shortcut in linux desktop to execute that order.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-04 12:02:56 -0500

rafarob gravatar image

Thank you so much. I found another possible order which also works

$ sage -n default directory="/home/username/mysagenotebook.sagenb"

edit flag offensive delete link more
0

answered 2014-12-03 10:53:40 -0500

You are right, this is broken in 6.4.1, a side-effect of a redesign of how the arguments of a command-line call to the notebook are parsed (the redesign was aimed at improving support for the ipython notebook in Sage).

Discussion on this sage-support thread reveals that after applying trac ticket #17439 you can run this command:

$ sage --notebook=sagenb "/home/username/mysagenotebook.sagenb"

Provided the fix in ticket #17439 is quickly reviewed, this should make it into one of the next Sage 6.5 betas, and be part of Sage 6.5 when it comes out.

You can read more about the recent changes to the parsing of arguments of command-line calls to the notebook on trac ticket #17280.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-03 04:13:39 -0500

Seen: 220 times

Last updated: Dec 04 '14