Ask Your Question
0

Are the Pari-GP functions Ploth & Plothsize supported by SAGE ?

asked 2014-11-26 18:43:15 -0500

The Pari-GP functions Ploth & Plothsize are failing within SAGE

Both Ploth & Plothsize are returning the "high resolution graphics disabled" message. There are several references on the Pari-GP website to this error messages.

These functions work fine on my standalone windows version of Pari-GP

eg: ploth(X = 0,2*Pi,[sin(X),cos(X)],1) will draw a circle.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-11-27 06:26:21 -0500

John Cremona gravatar image

By default Sage builds the pari library with graphics support disabled. I imagine that this is because the graphics support provided by Sage itself is much more sophisticated. If you read the script which does the building of pari (in the Sage source tree this is the file build/pkgs/pari/spkg-install) there are some comments about this, including how to build pari with graphics support. I have not tried it but it looks as if you just have to set the environment variable PARI_CONFIGURE to either "--graphic=auto" or "--with-fltk" before building Sage from source. This would not work from a binary download, but if you have already built from source then try setting this variable, then running "sage -f pari" (to force a recompilation of pari) and then "make" in the Sage root directory (to rebuild stuff which depends on the pari library) might work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-26 18:43:15 -0500

Seen: 76 times

Last updated: Nov 27 '14