Ask Your Question
0

notebook: localhost 8080 vs 8000

asked 2013-09-06 15:54:58 -0500

TumericTJ gravatar image

I used Sage v. 5.0 for the first time in a while and couldn't connect to the notebook. I received the message: Firefox can't establish a connection to the server at localhost:8000.

I was still able to use Sage from the command line, but decided to install v. 5.11 to see if that would fix my problem.
In fact, it did; and now the notebook opens at localhost:8080.

Does anyone know the reason for this?

edit retag flag offensive close merge delete

Comments

This was just a change decided on with one of the notebook upgrades, it's not a bug. I'm not really sure about the rationale, though I think that 8000 was more popular so it was better to use 8080.

kcrisman gravatar imagekcrisman ( 2013-09-06 16:53:09 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-09-06 23:48:57 -0500

tmonteil gravatar image

updated 2013-09-06 23:50:01 -0500

8000 or 8080 are arbitrary default choices. This default choice changed when the notebook became flask-based (see this ticket). You can specify the port you want as follows:

from Sage command line:

notebook(port=8888)

or from a shell:

sage -notebook port=8888
edit flag offensive delete link more
0

answered 2013-09-07 06:15:39 -0500

ppurka gravatar image

IIRC, the default port was changed in keeping with the official/unofficial suggestions for port numbers. See Wikipedia :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-09-06 15:54:58 -0500

Seen: 884 times

Last updated: Sep 07 '13