Cannot reset password as a user

asked 2013-09-03 13:15:56 -0500

paulavery1951 gravatar image

Using MaxOSX 10.8.4, with Sage 5.31

I've been using Sage as admin for several days, running it by clicking on the executable in /Applications to run it. Overall, it runs reasonably OK.

The problem is when I try to create a new user (me). I create the user account (which, by the way has a bad interface because you are put into an infinite loop of creating users with no escape).

So I create the user, save the password and login as the new user. That works. I then try to change the password, typing in the old one and new one (twice). Then I sign out and login again as the user. Sage does not accept the new password. Now neither the old or new passwords works, so the account is unusable. I then login again as admin and delete the account. I repeated the account creation/change password process 3 more times, being very careful to type in the password very carefully. It fails the same way every time! What is going on?

edit retag flag offensive close merge delete

Comments

What is sage 5.31? There is no such version. As for your bug, this bug was fixed in some later version of sage. It works in at least sage-5.10. I don't have an earlier version of sage in which I can test.

ppurka gravatar imageppurka ( 2013-09-03 13:59:46 -0500 )edit

Sorry, it's actually 5.11 which I downloaded a couple of weeks ago, so it's no doubt the latest version. I just didn't read the version number carefully. As I mentioned, I'm not running Sage from the command line, and I don't know if that can have anything to do with it. I can get by as admin without logging in as a user, but it's frustrating that I can't get such an elementary part of the system to work.

paulavery1951 gravatar imagepaulavery1951 ( 2013-09-03 17:41:01 -0500 )edit

This works for me in 5.11. Not sure why you are having trouble with it.

ppurka gravatar imageppurka ( 2013-09-03 19:11:23 -0500 )edit

Tried again by resetting the password from the admin account. Again, I can login with that password but once I try to change it while I am logged in as the user, the new password (as well as the old one) fails. Can this problem be a result of using Mountain Lion?

paulavery1951 gravatar imagepaulavery1951 ( 2013-09-04 08:04:12 -0500 )edit

Tried again by resetting the password from the admin account. Again, I can login with that password but once I try to change it while I am logged in as the user, the new password (as well as the old one) fails.

paulavery1951 gravatar imagepaulavery1951 ( 2013-09-04 08:04:13 -0500 )edit