Ask Your Question

Revision history [back]

See first my remark to the remarks of Slelievre and Iguananaut above. I will need to explain the parts of the solution in order reverse to the order in which they were discovered. The last and most important observation is that Iguananaut is right and both jmol and threejs work (used in the way described in the question) if the Jupyter NB is opened in Chrome. The second observation is that the default settings in Windows 10 make it impossible for Jupyter NB to open in Chrome, that is, administrative rights are needed to disable some components off. The third observation is that as soon as these changes are made, the operating system forbids the automatic access to the Jupyter NB config file. From this moment on, the problem about launching Jupyter NB js solved in the same way for SageMath and for Anaconda (and the solution (for the case of Anaconda) can be found in the Internet): the Jupyter NB config file is opened in, say, Notepad, and it is found to contain a certain link which, when pasted into Chrome, launches Jupyter NB with full functionality of jmol and almost full functionality of threejs (some of the spatial, opacity, etc. controls of three.js are missing, but the effect of this is minor). The steps of the solution in order of their execution: 1. Uninstall SageMath (if there is a previous installation, even if it is of the latest version - currently Sage 9.1); 2. Open MS start menu; 2-click on Settings at the leftmost vertical menu; 3. 2-Click on Apps. 4. Upper-right, 2-click on 'Programs and Features'; 5. Upper-left, 2-click on 'Turn Windows features on or off' 6. Provide administrative name and password 7. In the appearing menu, turn OFF: 1. Internet Explorer 11 and 2. Microsoft Print to PDF (otherwise this one converts Chrome pages to PDF version in which Jupyter NB is accessible but both jmol and threejs are not working), 3. Media Features (I am not sure about item 3 but turned it off, anyway). If something does not work at the end of the algorithm, you should return to step 7 and consider turning more features off, until success (working jmol and threejs in Jupyter NB) is achieved. 8. Uninstall any browser other than Chrome and Microsoft Edge. (In my case, I uninstalled Firefox. Without doing this, after the execution of step 7 above, and despite the fact that Chrome was selected as the primary browser in the operating system, in the newly installed Sage 9.1 (see step 9 below) Jupyter NB opened in Firefox, and not in Chrome (!!!).) Microsoft Edge proved to be irrelevant in this context. 9 Reinstall (full installation) Sage 9.1. At the end of the installation, Jupyter NB DOES NOT OPEN -- IN CHROME OR ANYWHERE. Information from the terminal indicates that the reason for this is that at this point the operating system (i.e., Windows 10) forbids automatic access to the config file of Jupyter NB (the exact path to, and name of, the file is given in the terminal message). (These were a lot of 'this' and 'that'! :) ) 10. Open the said config file, say, in Notepad, and copy the full internet address given there. 11. Paste the full internet address from step 10 into a new Chrome webpage: the Jupyter NB is launched; open a new Sage 9.1 notebook and verify on an appropriate 3d example that the viewers jmol and threejs work properly, alongside tachyon.

I believe that after this, one can reinstall Firefox and other browsers as secondary browsers, but I have not done this myself, so the correctness of this claim has not been tested yet.

Iguananaut, for your valuable input you deserve to be raised to rank Godzillanaut! :) Thanks once again.

I proposed the following solution some time ago, and now figured out a simplification of this solution, which I post separately in my remark to this solution -- see below. The users who are interested only in the practical solution of making jmol and threejs work under Windows 10, should skip the rest of the text here and read only my remark following this text. Users who are interested to know more about the reasons why jmol and threejs do not work under the default settings of Windows 10 can read the remaining part of this text, and then treat my remark below only as a shortcut of the solution given here.

See first my remark to the remarks of Slelievre and Iguananaut above. I will need to explain the parts of the solution in order reverse to the order in which they were discovered. The last and most important observation is that Iguananaut is right and both jmol and threejs work (used in the way described in the question) if the Jupyter NB is opened in Chrome. The second observation is that the default settings in Windows 10 make it impossible for Jupyter NB to open in Chrome, that is, administrative rights are needed to disable some components off. The third observation is that as soon as these changes are made, the operating system forbids the automatic access to the Jupyter NB config file. From this moment on, the problem about launching Jupyter NB js solved in the same way for SageMath and for Anaconda (and the solution (for the case of Anaconda) can be found in the Internet): the Jupyter NB config file is opened in, say, Notepad, and it is found to contain a certain link which, when pasted into Chrome, launches Jupyter NB with full functionality of jmol and almost full functionality of threejs (some of the spatial, opacity, etc. controls of three.js are missing, but the effect of this is minor). The steps of the solution in order of their execution: 1. Uninstall SageMath (if there is a previous installation, even if it is of the latest version - currently Sage 9.1); 2. Open MS start menu; 2-click on Settings at the leftmost vertical menu; 3. 2-Click on Apps. 4. Upper-right, 2-click on 'Programs and Features'; 5. Upper-left, 2-click on 'Turn Windows features on or off' 6. Provide administrative name and password 7. In the appearing menu, turn OFF: 1. Internet Explorer 11 and 2. Microsoft Print to PDF (otherwise this one converts Chrome pages to PDF version in which Jupyter NB is accessible but both jmol and threejs are not working), 3. Media Features (I am not sure about item 3 but turned it off, anyway). If something does not work at the end of the algorithm, you should return to step 7 and consider turning more features off, until success (working jmol and threejs in Jupyter NB) is achieved. 8. Uninstall any browser other than Chrome and Microsoft Edge. (In my case, I uninstalled Firefox. Without doing this, after the execution of step 7 above, and despite the fact that Chrome was selected as the primary browser in the operating system, in the newly installed Sage 9.1 (see step 9 below) Jupyter NB opened in Firefox, and not in Chrome (!!!).) Microsoft Edge proved to be irrelevant in this context. 9 Reinstall (full installation) Sage 9.1. At the end of the installation, Jupyter NB DOES NOT OPEN -- IN CHROME OR ANYWHERE. Information from the terminal indicates that the reason for this is that at this point the operating system (i.e., Windows 10) forbids automatic access to the config file of Jupyter NB (the exact path to, and name of, the file is given in the terminal message). (These were a lot of 'this' and 'that'! :) ) 10. Open the said config file, say, in Notepad, and copy the full internet address given there. 11. Paste the full internet address from step 10 into a new Chrome webpage: the Jupyter NB is launched; open a new Sage 9.1 notebook and verify on an appropriate 3d example that the viewers jmol and threejs work properly, alongside tachyon.

I believe that after this, one can reinstall Firefox and other browsers as secondary browsers, but I have not done this myself, so the correctness of this claim has not been tested yet.

Iguananaut, for your valuable input you deserve to be raised to rank Godzillanaut! :) Thanks once again.

I proposed the following solution some time ago, and now figured out a simplification of this solution, which I post separately in my remark to this solution -- see below. The users who are interested only in the practical solution of making jmol and threejs work under Windows 10, should skip the rest of the text here and read only my remark following this text. Users who are interested to know more about the reasons why jmol and threejs do not work under the default settings of Windows 10 can read the remaining part of this text, and then treat my remark below only as a shortcut of the solution given here.

See first my remark to the remarks of Slelievre and Iguananaut above. I will need to explain the parts of the solution in order reverse to the order in which they were discovered. The last and most important observation is that Iguananaut is right and both jmol and threejs work (used in the way described in the question) if the Jupyter NB is opened in Chrome. The second observation is that the default settings in Windows 10 make it impossible for Jupyter NB to open in Chrome, that is, administrative rights are needed to disable some components off. The third observation is that as soon as these changes are made, the operating system forbids the automatic access to the Jupyter NB config file. From this moment on, the problem about launching Jupyter NB js solved in the same way for SageMath and for Anaconda (and the solution (for the case of Anaconda) can be found in the Internet): the Jupyter NB config file is opened in, say, Notepad, and it is found to contain a certain link which, when pasted into Chrome, launches Jupyter NB with full functionality of jmol and almost full functionality of threejs (some of the spatial, opacity, etc. controls of three.js are missing, but the effect of this is minor). minor).

The steps of the solution in order of their execution: 1. execution:

  1. Uninstall SageMath (if there is a previous installation, even if it is of the latest version - currently Sage 9.1); 2. 9.1);
  2. Open MS start menu; 2-click on Settings at the leftmost vertical menu; 3.
  3. 2-Click on Apps. 4. Apps.
  4. Upper-right, 2-click on 'Programs and Features'; 5. Features';
  5. Upper-left, 2-click on 'Turn Windows features on or off' 6. off'
  6. Provide administrative name and password 7. password
  7. In the appearing menu, turn OFF: 1. Internet Explorer 11 and 2. Microsoft Print to PDF (otherwise this one converts Chrome pages to PDF version in which Jupyter NB is accessible but both jmol and threejs are not working), 3. Media Features (I am not sure about item 3 but turned it off, anyway). If something does not work at the end of the algorithm, you should return to step 7 and consider turning more features off, until success (working jmol and threejs in Jupyter NB) is achieved. 8. achieved.
  8. Uninstall any browser other than Chrome and Microsoft Edge. (In my case, I uninstalled Firefox. Without doing this, after the execution of step 7 above, and despite the fact that Chrome was selected as the primary browser in the operating system, in the newly installed Sage 9.1 (see step 9 below) Jupyter NB opened in Firefox, and not in Chrome (!!!).) Microsoft Edge proved to be irrelevant in this context. 9 Reinstall (full installation) Sage 9.1. At the end of the installation, Jupyter NB DOES NOT OPEN -- IN CHROME OR ANYWHERE. Information from the terminal indicates that the reason for this is that at this point the operating system (i.e., Windows 10) forbids automatic access to the config file of Jupyter NB (the exact path to, and name of, the file is given in the terminal message). (These were a lot of 'this' and 'that'! :) ) 10. )
  9. Open the said config file, say, in Notepad, and copy the full internet address given there. 11. there.
  10. Paste the full internet address from step 10 into a new Chrome webpage: the Jupyter NB is launched; open a new Sage 9.1 notebook and verify on an appropriate 3d example that the viewers jmol and threejs work properly, alongside tachyon.

I believe that after this, one can reinstall Firefox and other browsers as secondary browsers, but I have not done this myself, so the correctness of this claim has not been tested yet.

Iguananaut, for your valuable input you deserve to be raised to rank Godzillanaut! :) Thanks once again.