Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Now tried running the ...sagetex.sage files from two different locations, and two different documents.

On both, I cd via the terminal to ensure I'm in the directory / subdirectory containing the sagetex.sage files . I then try both approaches: Firstly running the sagetex.sage file from within the main sage-6.6 directory (using ./<name>.sagetex.sage) and then try again running from outside the sage-6.6 directory and the same ./ ... approach. I do not get the same error as before, but this time it gives me a syntax error on line 4 of the ...sagtex.sage files. Checking the syntax (the line checks that the versions match) I can see no obvious error - I'm assuming that the syntax is based on python syntax.

The other approach I've tried is to run the files from the interactive sage using the 'load' command. This also gives the original 'file not found' error. However, I think the python version is iPython, but I'm not clear whether this makes any difference.

The comment 'sage being finicky' is well made, I guess much of linux / ubuntu tends to involve a fair degree of trial and error. I'll keep trying and any other ideas are welcomed and if I get a result I'll obviously post it