Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Thank you for the response. I've read a little about this option and will be looking at it more.

I also found another alternative that answers my own question for those looking for a secure Sage server without the reverse proxy. Here are the steps: First, install pyopenssl spkg and set secure=True in the notebook parameters. Next, set interface='' (two single quotes) to listen on all available interfaces (localhost and physical) and uninstall HAProxy so the Sage server has a direct connection to the network. I added the iptables rule "iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 443 -j REDIRECT --to-port 8080" as described in the Setting Up a Sage Server article to redirect HTTPS requests to the Sage server and opened ports 443 and 8080 in the firewall. So far the Sage server seems to be working with full HTTPS. Hopefully these steps help someone else who is trying to do something similar.

Have a GREAT DAY!!