Ask Your Question

lsimons's profile - activity

2015-06-21 17:10:56 -0500 received badge  Famous Question (source)
2013-03-11 03:23:47 -0500 received badge  Notable Question (source)
2012-11-07 02:52:26 -0500 received badge  Popular Question (source)
2012-05-13 14:13:04 -0500 received badge  Nice Question (source)
2012-04-17 08:54:18 -0500 received badge  Supporter (source)
2012-04-17 08:54:17 -0500 marked best answer Sage Notebook in Virtualbox Visible to Localhost but not LAN

Did you read the instructions at http://wiki.sagemath.org/SageAppliance under "Giving Others Access to the Sage Virtual Machine"? They should spell out what you need step-by-step.

It is intentional that, by default, only the local computer user can connect to the virtual machine.

2012-04-17 08:54:17 -0500 received badge  Scholar (source)
2012-04-17 08:54:16 -0500 commented answer Sage Notebook in Virtualbox Visible to Localhost but not LAN

Once you configure for Bridged Adpater, then look-up the assigned IP of the sage VM via ifconfig (alt+f1) to get to the terminal login. Then access the VM via https://my-vm-ip:8000 on the network.

2012-04-17 08:43:57 -0500 commented answer Sage Notebook in Virtualbox Visible to Localhost but not LAN

Sorry. I had convinced myself it was a VirtualBox configuration and had forgotten to check the Sage docs. That's embarassing. I modified the .bash_profile to start in secure mode with logins, and that worked fine at https://localhost:8000. However, when I change the network adapter to Bridged Adapter, sage fails to start with "Can't check status of PID 1299 from pidfile /home/sage.sage/sage_notebook.sagenb/twistd.pid: Operation not permitted".

2012-04-17 07:56:05 -0500 received badge  Student (source)
2012-04-17 07:48:58 -0500 asked a question Sage Notebook in Virtualbox Visible to Localhost but not LAN

I have been running the Sage Notebook VirtualBox VM happily for a while now, and would like to share the results within my LAN. I currently access Sage via http://localhost:8000, so the NAT port forwarding appears fine. However, I get "Unable to Connect" if I try http://my-computer-name:8000 or http://my-computer-ip:8000. I've tried allowing VirtualBox to open ports in the firewall settings.

I'm running Sage-4.7.1 in VirtualBox 4.0.10 on Windows 7 x64.

Thanks, Louis