Ask Your Question

Ricardo24's profile - activity

2020-04-04 16:25:06 +0100 asked a question How to use a python lib by sageMath?

Hello,

Here's my problem :

I have sage v.9 in my Debian 4.9 and I want to use it by importing a python lib that I downloaded from a private repo on Github. This library is in a repo in which there is a makefile in which I have to indicate the path of sage's binary, otherwise I can't run a make. The first line of the makefile is : SAGE= but the problem is, I don't know what is the path I should indicate. To launch sagev9, I do cd /home/my_name/SageMath/ && ./sage.

So with HOME=/home/my_name, I tried :

SAGE=$(HOME)/SageMath/sage

SAGE=$(HOME)/SageMath/local/bin/sage

SAGE=$(HOME)/SageMath/src/bin/sage

but none of them works. When I type make, I received the error : Error: You must set the SAGE_ROOT environment variable or run this script from the SAGE_ROOT or SAGE_ROOT/local/bin/ directory. Error setting environment variables by sourcing '/home/rachidi/SageMath/local/bin/sage-env';

Do you please know what path I have to indicate?

Thanks.

2020-04-04 16:25:06 +0100 asked a question How to use a python lib by sage?

Hello,

Here's my problem :

I have sage v.9 in my Debian 4.9 and I want to use it by importing a python lib that I downloaded from a private repo on Github. This library is in a repo in which there is a makefile in which I have to indicate the path of sage's binary, otherwise I can't run a make. The first line of the makefile is : SAGE= but the problem is, I don't know what is the path I should indicate. To launch sagev9, I do cd /home/my_name/SageMath/ && ./sage.

So with HOME=/home/my_name, I tried :

SAGE=$(HOME)/SageMath/sage

SAGE=$(HOME)/SageMath/local/bin/sage

SAGE=$(HOME)/SageMath/src/bin/sage

but none of them works. When I type make, I received the error : Error: You must set the SAGE_ROOT environment variable or run this script from the SAGE_ROOT or SAGE_ROOT/local/bin/ directory. Error setting environment variables by sourcing '/home/rachidi/SageMath/local/bin/sage-env';

Do you please know what path I have to indicate?

Thanks.