Ask Your Question

orenshani7's profile - activity

2019-03-10 01:10:11 -0500 commented answer Is there a package for sagecell ?

Frederic,

This is the procedure I am following. It still requires running sagemath install which re installs everything...

Thanks,

Oren

2019-03-07 04:03:41 -0500 asked a question Is there a package for sagecell ?

I was trying to install sagecell on an ubuntu 18.04 machines for few days now... very frustrating...

sagecell install seems to reinstall the entire sage suit and then fails on this or that.

Is there another way? Some pre-prepared apt/pip package that only installs sagecell on top of the already existing cell installation?

Thanks,

Oren

2019-03-05 01:04:21 -0500 answered a question problems with sagecell

Okay I figured it out. An older version of fabric is needed apparently. See here:

https://unix.stackexchange.com/questi...

Oren

2019-03-05 00:19:49 -0500 commented answer problems with sagecell

Eric,

I tried that but apparently, my sage installation does not support the -pip option. I don't see it in the docs either:

http://doc.sagemath.org/html/en/refer...

Do you have any idea why is this?

Thanks,

Oren

2019-03-04 18:30:01 -0500 received badge  Student (source)
2019-03-04 06:22:58 -0500 asked a question problems with sagecell

Hi All,

I installed sagemath on Ubuntu 18.04 and am now trying to install and configure sagecell

pip install sagecell seem to work ok, but when I try to run sagecell it says:

root@shilo-ubu4:/var/tmp# sagecell
Error: No module named 'fabric'. You can install it by typing:
    sudo pip install fabric
or
    su -c "pip install fabric"

And yet fabric is installed:

root@shilo-ubu4:/var/tmp# pip install fabric
Requirement already satisfied: fabric in /usr/local/lib/python2.7/dist-packages
Requirement already satisfied: paramiko>=2.4 in /usr/local/lib/python2.7/dist-packages (from fabric)
Requirement already satisfied: invoke<2.0,>=1.1 in /usr/local/lib/python2.7/dist-packages (from fabric)
Requirement already satisfied: cryptography>=1.1 in /usr/lib/python2.7/dist-packages (from fabric)
Requirement already satisfied: pynacl>=1.0.1 in /usr/local/lib/python2.7/dist-packages (from paramiko>=2.4->fabric)
Requirement already satisfied: pyasn1>=0.1.7 in /usr/lib/python2.7/dist-packages (from paramiko>=2.4->fabric)
Requirement already satisfied: bcrypt>=3.1.3 in /usr/local/lib/python2.7/dist-packages (from paramiko>=2.4->fabric)
Requirement already satisfied: six in /usr/lib/python2.7/dist-packages (from pynacl>=1.0.1->paramiko>=2.4->fabric)
Requirement already satisfied: cffi>=1.4.1 in /usr/local/lib/python2.7/dist-packages (from pynacl>=1.0.1->paramiko>=2.4->fabric)
Requirement already satisfied: pycparser in /usr/local/lib/python2.7/dist-packages (from cffi>=1.4.1->pynacl>=1.0.1->paramiko>=2.4->fabric)

So what am I missing here?

Thanks,

Oren