Ask Your Question

kjlvcxzoiperwq's profile - activity

2017-11-22 13:03:24 +0200 received badge  Famous Question (source)
2017-04-06 20:51:01 +0200 received badge  Great Question (source)
2016-11-04 21:00:02 +0200 received badge  Good Question (source)
2016-11-04 20:55:15 +0200 received badge  Famous Question (source)
2015-10-05 19:20:28 +0200 received badge  Notable Question (source)
2015-01-14 11:45:10 +0200 received badge  Popular Question (source)
2014-06-16 01:33:29 +0200 received badge  Nice Question (source)
2014-06-04 22:55:42 +0200 received badge  Notable Question (source)
2013-11-23 17:23:22 +0200 received badge  Popular Question (source)
2013-04-25 12:25:04 +0200 commented answer matplotlib x11 window

plt.savefig('') didn't do anything, and i tried everything on the link you provided, and that also didn't do anything.

2013-04-24 17:26:24 +0200 received badge  Student (source)
2013-04-24 14:54:01 +0200 received badge  Supporter (source)
2013-04-24 14:52:43 +0200 commented answer sage terminal colors

That worked. The file init.sage didn't exist so I had to create it myself.

2013-04-24 14:52:21 +0200 marked best answer sage terminal colors

You can try adding the line

%colors Linux

to the file $HOME/.sage/init.sage, that will make sage execute that command automatically at startup (taken from the sage FAQ).

2013-04-24 14:52:21 +0200 received badge  Scholar (source)
2013-04-24 14:31:12 +0200 received badge  Editor (source)
2013-04-24 14:28:01 +0200 asked a question matplotlib x11 window

In both Ipython and Python terminals I can type in the following

import matplotlib.pyplot as plt
plt.ylabel('some numbers')

and a nice x11 figure will pop up (example figure is shown at In sage, the statement just does nothing. Is there any way to make this work in sage? It is kindof neat at times that sage plotting functions just dump an image file and then launches an image viewer, but I need more primitive access to matplotlib sometimes and I also need to be able to interact with the figure sometimes. Why doesn't this work in the sage terminal?

2013-04-24 14:17:36 +0200 asked a question sage terminal colors

I just upgraded from sage version 4.8 to version 5.8. I was pleasantly surprised to see colouring of the text similar to ipython does. However, sage seems to be defaulting to colours geared towards white background and black text. I have a black background and white text. The default colour scheme is very hard to read and I can't figure out how to change it. I did find this web page ( but following the instructions in it does not work and my sage colour scheme is always that of figure 3 on the link, but my system terminal settings have a black background and white text. Although I would prefer the right colour scheme, the old pure black and white would be better than what I have now. How can I change the sage terminal colours to something more readable? I don't want to change my default system terminal settings.

I can type "%colors Linux" once I launch sage and it does then give me the colour scheme that I want, but I can't get the scheme to persist from session to session.

2013-04-05 01:17:03 +0200 commented question incompatible libgfortran version?

although I would have liked to know the cause of this for future reference, upgrading to the latest version of sage did resolve the issue somehow.

2013-04-01 11:11:31 +0200 commented answer incompatible libgfortran version?

user@user-cfd-workstation:~$ which gfortran /usr/bin/gfortran user@user-cfd-workstation:~$ sage -sh Starting subshell with Sage environment variables set. Be sure to exit when you are done and do not do anything with other copies of Sage! Bypassing shell configuration files ... SAGE_ROOT=/opt/sage-4.8-linux-64bit-ubuntu_10.04.3_lts-x86_64-Linux (sage subshell) user-cfd-workstation:~ user$ which gfortran /usr/bin/gfortran SAGE_ROOT=/opt/sage-4.8-linux-64bit-ubuntu_10.04.3_lts-x86_64-Linux (sage subshell) user-cfd-workstation:~ user$

2013-04-01 11:11:09 +0200 commented answer incompatible libgfortran version?

this didn't work. i checked, and it doesn't appear that sage -sh is causing a different compiler to be used. does this prove it?

2013-03-27 16:28:42 +0200 asked a question incompatible libgfortran version?

I am using a python code that someone else wrote that links to some fortran libraries. I can get the code to work with my system installation of python (Python 2.7.2+ default, Oct 4 2011, 20:06:09 [GCC 4.6.1] on linux2). My operating system is Ubuntu 11.10. When I try to use the same python code in sage, I get the following error:

OSError: /opt/sage-4.8-linux-64bit-ubuntu_10.04.3_lts-x86_64-Linux/local/lib/ version `GFORTRAN_1.4' not found (required by [omitting the full path on this website for privacy reasons]/

when the

ctypes.cdll.LoadLibrary(u"[omitting the full path on this website for privacy reasons]/")

command is run.

I really don't know anything about fortran or how ctypes works, but it appears as though the sage version that I am using has a different libgfortran version than my operating system used when I created the fortran object files from the fortran code and linked them with the gfortran command. Here is some output from the command "dpkg --list | grep compiler|grep fortran"

ii gfortran 4:4.6.1-2ubuntu5 GNU Fortran 95 compiler ii gfortran-4.6 4.6.1-9ubuntu3 GNU Fortran 95 compiler

Is there some way I can tell sage to use the same libgfortran as my system python distribution? Will updating sage resolve this issue?