Ask Your Question
0

How do I install a package 'TOPCOM'

asked 2012-09-16 22:55:43 -0500

admin gravatar image

Recently I have used the Sage Notebook for computing the triangulation of polytopes. To check the regularity of these triangulations, I need to install the package 'TOPCOM' in advance. But I can't install this software successfully. For example, if I command

sage: install_package('TOPCOM')

then there is a technical error and a caution; Error: failed to download

My laptop is a Mac OS X Version 10.6.8. Could you tell me how to fix this problem?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-01-04 08:04:24 -0500

updated 2013-01-05 15:57:08 -0500

kcrisman gravatar image

Volker, thank you for your answer. Alas, following your instructions produces exactly the same error message on my MacBookPro with OSX 10.8.2 as using the Sage session:

Weasel:sage user$ ./sage -f http://www.stp.dias.ie/~vbraun/Sage/spkg/TOPCOM-0.17.4.spkg
Attempting to download package TOPCOM-0.17.4
>>> Downloading TOPCOM-0.17.4.spkg.
[............................................................]
TOPCOM-0.17.4
====================================================
Extracting package /Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/optional/TOPCOM-0.17.4.spkg
-rw-r--r--  1 user  admin  901874 Jan  4 11:57 /Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/optional/TOPCOM-0.17.4.spkg
Finished extraction
****************************************************
Host system:
Darwin Weasel.local 12.2.1 Darwin Kernel Version 12.2.1: Thu Oct 18 16:32:48 PDT 2012; root:xnu-2050.20.9~2/RELEASE_X86_64 x86_64
****************************************************
C compiler: gcc
C compiler version:
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/local/bin/../libexec/gcc/x86_64-apple-darwin12.2.0/4.6.3/lto-wrapper
Target: x86_64-apple-darwin12.2.0
Configured with: ../src/configure --prefix=/Users/dehayebuildbot/build/sage/dehaye/dehaye_binary/build/sage-5.5/local --with-local-prefix=/Users/dehayebuildbot/build/sage/dehaye/dehaye_binary/build/sage-5.5/local --with-gmp=/Users/dehayebuildbot/build/sage/dehaye/dehaye_binary/build/sage-5.5/local --with-mpfr=/Users/dehayebuildbot/build/sage/dehaye/dehaye_binary/build/sage-5.5/local --with-mpc=/Users/dehayebuildbot/build/sage/dehaye/dehaye_binary/build/sage-5.5/local --with-system-zlib --disable-multilib  
Thread model: posix
gcc version 4.6.3 (GCC) 
****************************************************
WARNING: spkg-install is not executable, making it executable
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... ./install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/build/TOPCOM-0.17.4/src':
configure: error: C compiler cannot create executables
See `config.log' for more details
Error configuring TOPCOM.

real    0m1.300s
user    0m0.149s
sys 0m0.138s
************************************************************************
Error installing package TOPCOM-0.17.4
************************************************************************
Please email sage-devel (http://groups.google.com/group/sage-devel)
explaining the problem and including the relevant part of the log file
  /Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/logs/TOPCOM-0.17.4.log
Describe your computer, operating system, etc.
If you want to try to fix the problem yourself, *don't* just cd to
/Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/build/TOPCOM-0.17.4 and type 'make' or whatever is appropriate.
Instead, the following commands setup all environment variables
correctly and load a subshell for you to debug the error:
  (cd '/Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/spkg/build/TOPCOM-0.17.4' && '/Applications/Sage-5.5-OSX-64bit-10.8.app/Contents/Resources/sage/sage' -sh)
When you are done debugging, you can type "exit" to leave the subshell.
edit flag offensive delete link more

Comments

Do you have Xcode installed?

John Palmieri gravatar imageJohn Palmieri ( 2013-01-04 09:10:05 -0500 )edit

Though interestingly, it still says gcc is there, just that it doesn't work.

kcrisman gravatar imagekcrisman ( 2013-01-05 15:58:21 -0500 )edit

I'm guessing that it's the gcc installed in SAGE_ROOT/local/bin (note that this seems to be a binary installation of Sage), but I don't think that one will work unless Xcode has installed the various system libraries etc. I'm not sure, though.

John Palmieri gravatar imageJohn Palmieri ( 2013-01-05 18:28:54 -0500 )edit
0

answered 2012-09-16 23:42:17 -0500

Volker Braun gravatar image

Can you try the new spkg at Trac #13499? The easiest way is to open a terminal, go to the Sage directory, and run

[user@localhost Sage]$ ./sage -f http://www.stp.dias.ie/~vbraun/Sage/spkg/TOPCOM-0.17.4.spkg

Also ticket needs review if you want the updated version distributed with Sage...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-09-16 22:55:43 -0500

Seen: 349 times

Last updated: Jan 05 '13