Ask Your Question
2

Make sage not recreate plot files for sagetex

asked 2012-05-01 00:56:33 -0500

chaesloc2 gravatar image

When running sage on a .sagetex.sage file, it spends ages on "Initializing plots directory\n Plot 0". Most of the time I haven't changed the plots. How do I tell sage(tex) to use the files generated last time?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-05-01 10:03:31 -0500

Jason Grout gravatar image

updated 2012-05-01 10:08:52 -0500

You might use sagetexpause and sagetexunpause. See the sagetex manual (http://mirrors.ctan.org/macros/latex/...), section 3.4.

This may not display your old image, but it at least doesn't try to recreate it, I think.

edit flag offensive delete link more
0

answered 2012-05-01 05:35:53 -0500

kcrisman gravatar image

I don't know what system you are on, but using TeXShop on Mac, I just do Shift-Command-L (for LaTeX, no Sage) and that does this for me.

This doesn't answer the question if you need to use SageTeX on the file but not to change the plots, of course.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-01 00:56:33 -0500

Seen: 104 times

Last updated: May 01 '12