Ask Your Question
0

Fail to start: No module named IPython

asked 2012-04-26 22:43:40 -0600

anonymous user

Anonymous

Dear all, I've in stalled SAGE 4.8 on Ubuntu 12.04 LTS 64 bit.

When I try to excute Sage, I obtain the error

|Sage version 4.8, Release Date: 2012-01-20 |Type Notebook() for the GUI, and license() for information. Traceback (most recent call last): File "/home/user/sage/sage-4.8/local/bin/sage-ipython", line 18 in <module> import IPython

ImportError: No module named IPython

I have installed IPython but the error remains, either compiliong SAGE from scratch and using binary version

Thanks!

edit retag flag offensive close merge delete

Comments

Did you face this problem after upgrading the system from 11.10 to 12.04?

Shashank gravatar imageShashank ( 2012-04-27 11:37:15 -0600 )edit

I had just installed Ubuntu 12.04 from scratch, only to use SAGE

didiego gravatar imagedidiego ( 2012-04-28 02:02:51 -0600 )edit

I just finished installing 12.04 on my desktop and sage works well. How are you installing sage? Are you trying to build it from the source or just using the binaries? It is recommended that you use the binaries.

Shashank gravatar imageShashank ( 2012-04-28 12:54:54 -0600 )edit

Thanks for your support. I did both of them: I compiled it form source code and I used the binaries, with the same result. I have installed IPython using the 'standard' application manager that came with Ubuntu 12.04 - I don't know the name, but I think it is neither aptitude nor synaptic. Maybe it is only a problem regarding the correct path, but I can not fix it.

didiego gravatar imagedidiego ( 2012-04-28 23:06:33 -0600 )edit

That is strange. IPython is a part of sage binaries, so you don't have to install it. You just have to unpack the sage binaries and run ./sage from sage directory.

Shashank gravatar imageShashank ( 2012-04-29 11:59:10 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2012-05-04 08:17:53 -0600

didiego gravatar image

I have deleted the old 'sage' directory and downloades the binary. Now, all works correctly! I don't undestand what was wrong....

thanks for your support!

edit flag offensive delete link more

Comments

Interesting! I just tried to do the same but it didn't resolve the problem for me. One question: did you download sage-4.8-linux-64bit-ubuntu_10.04.3_lts-x86_64-Linux.tar.lzma? (That's what I did, but I notice there's also a file with "8.04.4" in the name.) Thanks!

erikm gravatar imageerikm ( 2012-05-05 07:35:51 -0600 )edit

The file I downloaded is: sage-4.8-linux-64bit-ubuntu_10.04.3_lts-x86_64-Linux.tar.lzma

didiego gravatar imagedidiego ( 2012-05-06 23:48:55 -0600 )edit
0

answered 2012-05-03 08:44:33 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

try installing the package libssl0.9.8, that helped for me:

sudo apt-get install libssl0.9.8

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-04-26 22:43:40 -0600

Seen: 806 times

Last updated: May 04 '12