Ask Your Question

Plotting in sage 4.8 defaults to firefox, WHY?

asked 2012-02-02 21:02:01 +0200

root gravatar image

I have just installed sage 4.8. On my system I have gnuplot, gnuplotpy, surf,matplotlib, and perhaps some others. I want plot() in sage to default to ANY of these instead of bringing up firefox to plot a png.

I can get gnuplot if I use a maxima command. Is there any way to get sage to default to some other plot?

edit retag flag offensive close merge delete


Does [this]( answer your question?

kcrisman gravatar imagekcrisman ( 2012-02-02 21:28:46 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2012-02-02 21:58:13 +0200

root gravatar image

Partial fix: If I add this line to ~/.sage/init.sage: sage.misc.viewer.BROWSER='xv'

It gets rid of firefox, but it uses the minimally capable xv.

I have tried: sage.misc.viewer.PNG_VIEWER='xv' but then firefox is brought up.

If there is a need for a BROWSER setting then clearly xv will not do the trick.

edit flag offensive delete link more


The bit about PNG_VIEWER not working is surprising. One idea - in the ask.sagemath answer I referenced, there is mentioned in one of the comments. Try applying that patch and see if that helps out.

kcrisman gravatar imagekcrisman ( 2012-02-02 22:23:17 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2012-02-02 21:02:01 +0200

Seen: 370 times

Last updated: Feb 02 '12