Ask Your Question
0

h_vectors of simplicial complexes

asked 2011-03-25 00:44:51 -0600

EmersonL gravatar image

In the documentation for finite simplicial complexes it was described the function h_vector, but when I tried to use it, sage told me that there was not such a property for simplicial complexes. Where can it be the problem?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2011-03-25 00:48:21 -0600

DSM gravatar image

Could you edit your message to include a cut-and-paste of exactly what you did and what error message it returned? It seems to work for me just like in the examples, but I'm running Sage 4.6.2 and don't know about earlier versions:

sage: X = SimplicialComplex(3, [[0,1], [1,2], [2,3], [3,0]])
sage: X
Simplicial complex with vertex set (0, 1, 2, 3) and facets {(1, 2), (2, 3), (0, 3), (0, 1)}
sage: X.h_vector()
[1, 2, 1]
edit flag offensive delete link more

Comments

I have a 4.6.1 version of sage, but is installed somewhere else, so I cannot send you the precise error message. I think I should try an update... Thanks!

EmersonL gravatar imageEmersonL ( 2011-03-25 01:13:33 -0600 )edit

The patch for h-vectors was merged in Sage 4.6.2, so yes, you need to upgrade.

John Palmieri gravatar imageJohn Palmieri ( 2011-03-25 04:36:48 -0600 )edit
0

answered 2011-03-29 05:42:06 -0600

EmersonL gravatar image

I also noticed that there where no h_vectors in the old documentation... However I messed everything up with the upgrade and now nothing is working (I didn't check before the right way to do it and try to reinstall everything from the begining). This is the situation now: when I run ./sage I get a long message telling at the end:

 ImportError: libgfortran.so.3: cannot open shared object file: No such file or directory
Error importing ipy_profile_sage - perhaps you should run %upgrade?
WARNING: Loading of ipy_profile_sage failed.

then after running %upgrade I get the following

sage: %upgrade
> /home/emerson/sage-4.6.2/local/bin/python "/home/emerson/sage-4.6.2/local/lib/python2.6/site-packages/IPython/upgrade_dir.py" "/home/emerson/sage-4.6.2/local/lib/python2.6/site-packages/IPython/UserConfig" "/home/emerson/.sage/ipython"
/home/emerson/.sage/ipython/__init__.py: Unedited, installing new version
/home/emerson/.sage/ipython/ipy_user_conf.py: Unedited, installing new version

and then

sage: 1+1
---------------------------------------------------------------------------
NameError                                 Traceback (most recent call last)

/home/emerson/sage-4.6.2/local/bin/<ipython console> in <module>()

NameError: name 'Integer' is not defined

I hope you can tell me what to do now...

edit flag offensive delete link more

Comments

yes, I think deleting your old install and downloading a fresh copy of sage will be the quickest way to resolve this. Things from your ~/.sage directory (in particular, all of your notebook worksheets) should be unaffected by this.

niles gravatar imageniles ( 2011-03-29 09:59:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-25 00:44:51 -0600

Seen: 399 times

Last updated: Mar 29 '11