Ask Your Question
1

Sage 4.6 not compiling on OpenSuse 11.3 (x86_64)

asked 2010-12-11 13:18:28 +0200

JRL gravatar image

updated 2011-05-12 16:34:10 +0200

Kelvin Li gravatar image

Hi, I am having problems compiling Sage 4.6 (Opensuse 11.1) version on my Intel (x86_64) machine.

The FAQ's don't help resolve this.

The root directory is correctly set. I have tried several "distributions" and they all give the same problem.

Thanks for any pointers as to a solution!

/JRL

home>make cd spkg && ./install all 2>&1 | tee -a ../install.log /bin/ls: cannot access bzip2--install: No such file or directory /bin/ls: cannot access dir--install: No such file or directory /bin/ls: cannot access prereq-*-install: No such file or directory make[1]: Entering directory /usr/usr1/SAGE/sage-4.6-linux-64bit-fedora_release_13_goddard_-x86_64-Linux/spkg' standard/deps:142: warning: overriding commands for targetinstalled/' standard/deps:139: warning: ignoring old commands for target installed/' standard/deps:145: warning: overriding commands for targetinstalled/' standard/deps:142: warning: ignoring old commands for target installed/' make[1]: Circular installed/ <- installed/ dependency dropped. make[1]: Circular installed/ <- installed/ dependency dropped. make[1]: Circular installed/ <- installed/ dependency dropped. make[1]: Nothing to be done forall'. make[1]: Leaving directory `/usr/usr1/SAGE/sage-4.6-linux-64bit-fedora_release_13_goddard_-x86_64-Linux/spkg'

real 0m0.051s user 0m0.004s sys 0m0.005s To install gap, gp, singular, etc., scripts in a standard bin directory, start sage and type something like sage: install_scripts('/usr/local/bin')
at the Sage command prompt.

To build the documentation, run
make doc

Sage build/upgrade complete!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
-1

answered 2021-03-26 21:37:24 +0200

Presto.creator gravatar image

This won't be helpful, but the new one will work Even though this was 10 years ago

edit flag offensive delete link more

Comments

Some old unanswered questions are worth answering, but probably not those about compilation problems of a specific ten-year-old Sage version on a specific long-out-of-support operating system.

Answering them bumps them to the top of the list of questions on the front page, which is distracting.

slelievre gravatar imageslelievre ( 2021-03-26 23:37:12 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2010-12-11 13:18:28 +0200

Seen: 434 times

Last updated: Mar 26