Ask Your Question

v4.5.2 Upgrade Breaks Notebook, "got EOF subprocess must have crashed..."

asked 2010-08-30 18:19:18 +0200

disasteraverted gravatar image

I upgraded last week from v4.3 to v4.5.2 using the fantastic "sage -upgrade" command. The build and testing seem to work great, and everything starts up as normal. I log into the notebook, open a saved worksheet and everything seems fine. However, when I got to "evaluate" nothing happens at the browser level. Doing the same expression from the sage command line works fine.

Looking at the console, I see:

2010-08-30 10:24:21-0700 [HTTPChannel,49,] got EOF subprocess must have crashed...
2010-08-30 10:24:21-0700 [HTTPChannel,49,]
2010-08-30 10:24:21-0700 [HTTPChannel,49,] import os;os.chdir("/tmp/tmp_ECyTK");
2010-08-30 10:24:21-0700 [HTTPChannel,49,] execfile("")
2010-08-30 10:24:21-0700 [HTTPChannel,49,] The notebook files are stored in: nbfiles.sagenb
2010-08-30 10:24:21-0700 [HTTPChannel,49,] Another Sage Notebook server is running, PID 2517.
2010-08-30 10:24:21-0700 [HTTPChannel,49,]
2010-08-30 10:24:21-0700 [HTTPChannel,49,] Please either stop the old server or run the new server in a different directory.

Based on this I did some sluthing, and found that once I click on a worksheet (or create a new one), a new python process is spawned. However, that process dies almost immediately, complaining about another notebook server running... however, the notebook server running is the one I'm using, so not like I can stop it.

Is there any way to add logging/debugging to the spawned python process? Any ideas on where to go from here? I'm really stuck.



edit retag flag offensive close merge delete


ps -ef | grep twistd
Should show you the twisted process to kill.

ccanonc gravatar imageccanonc ( 2010-08-30 18:38:43 +0200 )edit

Thanks ccanonc, However, I don't think it's an issue, I think the error message is a misnomer. There is only one twistd process, and if I kill that I can't use the web interface. sageuser 8226 8197 4 07:40 ? 00:00:02 python /usr/local/sage-4.5.2/local/bin/twistd --pidfile=nbfiles. ...

disasteraverted gravatar imagedisasteraverted ( 2010-08-31 11:43:20 +0200 )edit

When you say: " The ... testing seem to work great," what do you mean, exactly? Did you type "make test" in SAGE_ROOT?

William Stein gravatar imageWilliam Stein ( 2010-08-31 15:02:55 +0200 )edit

Yes, I did a "make testlong" and got only a few errors (according to the power user here they are inconsequential)... a few tests timed out:,, These also failed:, Thanks, Nick

disasteraverted gravatar imagedisasteraverted ( 2010-08-31 17:21:06 +0200 )edit

If I run this manually, it works. i.e. cd /usr/local/sage; ./sage; then enter the appropriate notebook () command. If I use the ~sageuser/.sage/init.sage file to start the notebook with the same command it doesn't work. Must be some permissions minutia. Thanks for the ideas.

disasteraverted gravatar imagedisasteraverted ( 2010-09-03 15:05:38 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2010-09-03 19:03:51 +0200

Mitesh Patel gravatar image

updated 2010-09-03 19:05:51 +0200

Each worksheet process now loads $DOT_SAGE/init.sage (see #8092 for a bug fix we merged between Sage 4.3 and 4.5.2). If you call notebook() in this file, then each worksheet will try to start a new server in the default server directory. (You can change this with the directory keyword option, although that's likely not what you want to do here.)

To start a notebook server, I usually run a bash script that contains, e.g.,

sage -notebook interface='' open_viewer=False port=XXXXX secure=True

By the way, these and other options are described in notebook's docstring, accessible via notebook?.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2010-08-30 18:19:18 +0200

Seen: 2,396 times

Last updated: Sep 03 '10