Old Sage binaries

asked 2021-04-08 23:34:59 +0200

Does anyone know where I can find old Sage binaries (either for Linux or Mac OS)? By old, I mean version 4 or 5 (which I can't seem to compile with a recent version of Linux). I'm trying to install PSAGE (which I am struggling to install with recent versions of Sage).

edit retag flag offensive close merge delete

Comments

By PSage do you mean "purple sage" and are you getting it from

or from some other location?

slelievre gravatar imageslelievre ( 2021-04-09 01:25:48 +0200 )edit

@slelievre Yes, by PSage I mean 'Purple Sage'. The version I'm trying to install is from here https://github.com/martinra/psage/ (to be used in connection with some code for Hermitian modular forms). I've also tried the version you mention, but I can't seem to get it working with Sage 9.2, Sage 9.0 or Sage 6.10...

someguy gravatar imagesomeguy ( 2021-04-09 14:33:12 +0200 )edit

Binaries for SageMath 8.8 and 8.9 are still around, I would try those with Fredrik Strömberg's psage which is the most up to date and seems to have been updated for SageMath 8.7.

slelievre gravatar imageslelievre ( 2021-04-09 16:56:14 +0200 )edit

The develop branch here (https://github.com/fredstro/psage/tre...) is supposed to be compatible with recent versions of sage, if I understand correctly.

FrédéricC gravatar imageFrédéricC ( 2021-04-09 18:50:21 +0200 )edit