Problem installing Sage

asked 2021-01-11 12:33:46 -0600

jgs gravatar image

Hi:

I'm not sure if this is the right place to post this question. I tried to send an email to sage-support@googlegroups.com but got it back from the server. I am trying to install Sage on an Ubuntu (18.04.5 LTS), 64-bit. I tried to install (but couldn't) from the tar file on the webpage. The crash appears after executing ./sage while trying to install it and gives the following log. Do you have any idea what I'm doing wrong?

Thanks, Javi

***************************************************************************

IPython post-mortem report

{'commit_hash': 'd0b255042',
 'commit_source': 'installation',
 'default_encoding': 'utf-8',
 'ipython_path': '/home/javi/Work/Sage/SageMath/local/lib/python3.8/site-packages/IPython',
 'ipython_version': '7.13.0',
 'os_name': 'posix',
 'platform': 'Linux-5.4.0-58-generic-x86_64-with-glibc2.2.5',
 'sys_executable': '/home/javi/Work/Sage/SageMath/local/bin/python3',
 'sys_platform': 'linux',
 'sys_version': '3.8.5 (default, Oct 25 2020, 04:30:42) \n[GCC 9.2.0]'}

***************************************************************************



***************************************************************************

Crash traceback:

---------------------------------------------------------------------------
---------------------------------------------------------------------------
ImportError   Python 3.8.5: /home/javi/Work/Sage/SageMath/local/bin/python3
                                                   Mon Jan 11 13:20:23 2021
A problem occurred executing Python code.  Here is the sequence of function
calls leading up to the error, with the most recent (innermost) call last.
~/Work/Sage/SageMath/src/bin/sage-ipython in <module>
      1 #!/usr/bin/env sage-python
      2 # -*- coding: utf-8 -*-
      3 """
      4 Sage IPython startup script.
      5 """
      6 
      7 # Display startup banner. Do this before anything else to give the user
      8 # early feedback that Sage is starting.
      9 from sage.misc.banner import banner
     10 banner()
     11 
     12 from sage.repl.interpreter import SageTerminalApp
     13 
     14 app = SageTerminalApp.instance()
---> 15 app.initialize()
        global app.initialize = <bound method TerminalIPythonApp.initialize of <sage.repl.interpreter.SageTerminalApp object at 0x7f26aa500880>>
     16 app.start()

</home/javi/Work/Sage/SageMath/local/lib/python3.8/site-packages/decorator.py:decorator-gen-113> in initialize(self=<sage.repl.interpreter.SageTerminalApp object>, argv=None)

[... lots of other parts of the code where it fails...]

ImportError: /usr/lib/x86_64-linux-gnu/libgomp.so.1: version `GOMP_5.0' not found (required by /home/javi/Work/Sage/SageMath/local/lib/python3.8/site-packages/sage/matrix/matrix_modn_sparse.cpython-38-x86_64-linux-gnu.so)
edit retag flag offensive close merge delete