Cocalc: change texmf.cnf file

asked 2020-09-11 20:22:56 -0500

dazedANDconfused gravatar image

I'm trying to use sagetex to plot 3d graphics in LaTeX. I can get the basic plot to work but there isn't enough detail. When I try to create more points in my plot I get the message: "! Unable to read an entire line---bufsize=200000. Please increase buf_size in texmf.cnf.". I found a texmf.cnf file on my system, made a copy of it with a modification of the bufsize to read "buf_size = 1000000" and uploaded it to my Cocalc project. Following this FAQ page I created ~/texmf/tex/latex/local and moved my texmf.cnf file there, When that didn't work, I tried texhash ~/texmf as suggested. However, I still get the message "! Unable to read an entire line---bufsize=200000. Please increase buf_size in texmf.cnf."

How do I change the bufsize on Cocalc? Are there any guidelines on a reasonable buf_size value to increase to?

edit retag flag offensive close merge delete

Comments

1

Please share code that others can use to reproduce the problem: minimal .tex document with the minimal plot that illustrates this.

Other places this question could be asked:

  • TeX - LaTeX Stack Exchange
  • CoCalc support: in CoCalc, from the document where this is happening, click the "help" button. Then the CoCalc support team can have a look right there.
slelievre gravatar imageslelievre ( 2020-09-12 04:54:54 -0500 )edit

This question seems very specific of Cocalc's TeX setup, therefore better addresed to Cocalc's support team...

Emmanuel Charpentier gravatar imageEmmanuel Charpentier ( 2020-09-12 06:34:49 -0500 )edit

I've emailed Cocalc support for help. Should I delete this question?

dazedANDconfused gravatar imagedazedANDconfused ( 2020-09-12 10:31:44 -0500 )edit

If you solved your problem you could post an answer here to help anyone with the same problem.

slelievre gravatar imageslelievre ( 2020-09-12 22:04:29 -0500 )edit