Ask Your Question
1

plot3d() not working with firefox?

asked 2020-09-06 08:18:44 +0200

Alex89 gravatar image

updated 2020-09-06 13:44:11 +0200

Yesterday I switched my browser from Chromium to Firefox and when I try to use plot3d() the output shows no graph.

f(x,y) = x^2 + y^2 - x*y
plot3d(f,(x,-8,8),(y,-8,8))

Everything is white where the graph should be. I do see the small i at the bottom right of the window, but nothing else. Am I doing something wrong here?

Ubuntu 20.04 / Firefox 80.0.1 / Sage 9.0 / Sage was installed via terminal.

edit retag flag offensive close merge delete

Comments

What operating system? What version of Firefox? What version of Sage? How was Sage installed?

slelievre gravatar imageslelievre ( 2020-09-06 12:29:26 +0200 )edit

Ubuntu 20.04 / Firefox 80.0.1 / Sage 9.0 / Sage was installed via terminal.

Alex89 gravatar imageAlex89 ( 2020-09-06 13:41:13 +0200 )edit

By "installed by terminal" do you mean with sudo apt install? or git clone + make? or conda?

slelievre gravatar imageslelievre ( 2020-09-07 01:53:12 +0200 )edit

sudo apt-get install sagemath

Alex89 gravatar imageAlex89 ( 2020-09-07 07:47:01 +0200 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-09-06 21:42:52 +0200

tmonteil gravatar image

Could you please try to install firefox-esr and tell if it is still buggy ?

edit flag offensive delete link more

Comments

I didn't know what version you wanted me to install so I installed both that are available on Ubuntu-20.04.

firefox-esr 68.12 has the same issue, plot3d() does not show anything.

firefox-esr 78.2 the issue seems to be gone, plot3d() works normal.

Alex89 gravatar imageAlex89 ( 2020-09-07 13:56:04 +0200 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-09-06 08:18:44 +0200

Seen: 92 times

Last updated: Sep 06 '20