sage 9.1 installation problem

asked 2020-06-10 06:53:25 -0500

Javidlg gravatar image

I have downloaded sage-9.1-Ubuntu_18.04-x86_64.tar.bz2 binary into a folder named Sage 9.1. Then from that location on terminal I typed:

./sage

A patching sequence started with the final mesagge:

Error: The path to the Sage directory ($SAGE_ROOT) MUST NOT contain spaces.
It is currently "/home/javi/Sage 9.1/SageMath".
Please correct this by moving Sage (or renaming one or more directories) first.
Exiting now...
Error setting environment variables by sourcing '/home/javi/Sage 9.1/SageMath/src/bin/sage-env';
possibly contact sage-devel (see http://groups.google.com/group/sage-devel).

Then I thought "this must be fixed by changing the directory name"...wroooong. I changed the path to /home/javi/sage/sage-9.1 (changed "Sage 9.1" for "sage" and "SageMath" for "sage-9.1"). Then run again

./sage

and gave me:

It seems that you are attempting to run Sage from an unpacked source
tarball, but you have not compiled it yet (or maybe the build has not
finished). You should run `make` in the Sage root directory first.
If you did not intend to build Sage from source, you should download
a binary tarball instead. Read README.txt for more information.

Aditionally I have:

$python --version
Python 3.7.7

Would anybody help me? Thank you in advance.

edit retag flag offensive close merge delete

Comments

4

Could you restart from scratch, i.e. untar sage-9.1-Ubuntu_18.04-x86_64.tar.bz2 in a directory without any space in the name?

eric_g gravatar imageeric_g ( 2020-06-10 07:16:09 -0500 )edit

Thank you very much @eric_g for your response! indeed, It worked! Do I have to update my post??

Javidlg gravatar imageJavidlg ( 2020-06-12 17:14:54 -0500 )edit