Sage 8.5 on MacOS10.14 asking for Xcode command line tools

asked 2018-12-30 13:22:52 -0600

Tony-64 gravatar image

updated 2019-01-07 15:16:56 -0600

Has anyone seen a pop-up window asking for the Xcode command line tools to be installed after starting sage-8.5-OSX_10.14.2-x86_64.app? The pop-up says they are required to run gcc. I have just installed this version on a clean machine running MacOS 10.14.2 (no Xcode or older sage version installed). Sage appears to run fine without these tools, so for now I am just ignoring the pop up. Which functionality won't be available without having them installed?

BTW: I have observed the same pop up with sage 8.4 on MacOS 10.14. I haven't seen it with earlier sage versions on MacOS 10.13.

BTW2: The log file doesn't mention gcc missing.

UPDATE: Unfortunately, Sage does not run fine. It starts OK and runs relative simple code aw expected. However, when trying to execute more complicated code, Sage unexpectedly throws runtime errors and floating point exceptions. The only way to get Sage running as expected is to install the Xcode command line tools. (No need to install the full Xcode environment).

Perhaps this should be mentioned somewhere in the docs?

edit retag flag offensive close merge delete