Ask Your Question
1

downloaded binary, but got a msg that I still need to compile

asked 2018-07-11 00:07:08 -0500

paul1963 gravatar image

~/SageMath/sage shows as an executable, as do many other files in the various directories, so it doesn't seem that I need to compile.. nonetheless the Makefile and related are present in~/SageMath.. tried running make, but that failed with Makefile:20: recipe for target 'all' failed.. what next?

edit retag flag offensive close merge delete

Comments

which OS ? which version of this OS ? which version of sage ? more details are required..

FrédéricC gravatar imageFrédéricC ( 2018-07-11 02:22:01 -0500 )edit
1

This might be related to

Note: that page can be found searching the web for [ "Makefile:20: recipe for target 'all' failed" sagemath ].

slelievre gravatar imageslelievre ( 2018-07-11 05:00:05 -0500 )edit

tnx Sagehelp, esp slelievre.. and whoever figured this out because I never would have in a million hours.. I needed to comment out a line that anaconda put in my .bashrc... now it works.. wow..

paul1963 gravatar imagepaul1963 ( 2018-07-14 19:20:05 -0500 )edit

1 answer

Sort by » oldest newest most voted
2

answered 2018-07-14 19:27:47 -0500

paul1963 gravatar image

It is necessary to comment out a path modification that Anaconda adds to one's .bashrc This with SageMath version 8.2 on a 64 bit HP running Ubuntu 17, Linux 4.13 tnx all

edit flag offensive delete link more

Comments

You can accept your own answer.

slelievre gravatar imageslelievre ( 2018-07-15 04:24:53 -0500 )edit

Depending on your system, Anaconda might add such a line in ~/.bashrc or ~/.bash_profile.

slelievre gravatar imageslelievre ( 2018-07-15 04:25:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-07-11 00:07:08 -0500

Seen: 32 times

Last updated: yesterday