Ask Your Question
0

can not install -> segmentation fault

asked 2018-02-26 22:35:23 -0600

I am running MacOSX 10.6.8 Here is what I get

"/Applications/SageMath-7.1.app/Contents/Resources/sage/src/bin/sage-env: line 407: 2160 Segmentation fault "$SAGE_ROOT/local/bin/python" -c 'import pkg_resources; pkg_resources.get_distribution("matplotlib").version' 2> /dev/null"

AND this

"/Applications/SageMath-7.1.app/Contents/Resources/sage/src/bin/sage: line 387: 2172 Segmentation fault sage-location logout"

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-02-27 10:21:03 -0600

kcrisman gravatar image

Oh, that is a bummer. We do not currently create binaries for OS X 10.6; the least recent system we do it for is OS X 10.11! There are two possibilities for you, if a newer binary doesn't work (which it may not).

1) There are some older binaries you can download. But I don't know if any of them are for that old of a system. Exactly which binary do you have downloaded? Sage 7.1 is already nearly two years old.

2) You could try building from scratch.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-26 22:35:23 -0600

Seen: 23 times

Last updated: Feb 27