Ask Your Question
1

Ploting 3D difference between VirtualBox Linux versus W10

asked 2018-01-30 11:46:12 -0500

ortollj gravatar image

Hi

Sage8.0.

there is a difference Between SageMath under VirtualBox Linux VM : Nice graph, or SageMath under W10 :no graph at all when executing this code in notebook.

x, y = var('x y')
W = plot3d(sin(pi*((x)^2+(y)^2))/2,(x,-1,1),(y,-1,1), frame=False, color='purple', opacity=0.8)
S = sphere((0,0,0),size=0.3, color='red', aspect_ratio=[1,1,1])
show(W + S, figsize=8)

Plotting Functions Example

edit retag flag offensive close merge delete

Comments

Can you specify the notebook you are using? Jupyter or the legacy notebook? Besides, you may consider upgrading to SageMath 8.1. Maybe the problem is fixed there.

eric_g gravatar imageeric_g ( 2018-01-31 06:26:34 -0500 )edit

Hi eric_g I don't know if it is Jupyiter or legacy notebook. The only thing I know is that I click on my desk on a kind of blue spherical polygon , then a shell named "sagemath 8.0 notebook Server" appears, then in my EdgeBrowser (Microsoft Edge 41.16299.15.0) I can see a page " \localhost\8888 " then i click on new -> sageMath 8.0 .

I'm gonna try Sagemath Windows 8.1(Sorry,I did not.know there is a 8.1) and I'll tell you the result.

ortollj gravatar imageortollj ( 2018-01-31 11:13:04 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2018-01-31 20:54:12 -0500

ortollj gravatar image

with the 8.1 it still does not work with Edge or IE but it's OK with the Chrome Browser !, (I did not try with Chrome in 8.0). it works when I copy the url in a chrome browser and I copied the tocken given in the "sageMath 8.1 Notebook Server" Shell, then I cans see the nice graph !

edit flag offensive delete link more
0

answered 2018-01-31 22:39:31 -0500

slelievre gravatar image

One trick that might solve your problem is to use the "threejs" viewer.

For that, specify the viewer in the show command.

That is, replace your last line by the following:

show(W + S, figsize=8, viewer="threejs")
edit flag offensive delete link more

Comments

for me

show(W + S, figsize=8, viewer="threejs")

does not work in Edge. the simplest solution is simply to choose chrome for default browser. and everything is ok.

ortollj gravatar imageortollj ( 2018-02-01 22:56:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-30 11:46:12 -0500

Seen: 52 times

Last updated: Jan 31