Ask Your Question
1

How to install cantera on SAGE (OS X)?

asked 2017-09-28 02:19:41 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Cantera installation use brew for Mac os x, http://www.cantera.org/docs/sphinx/html/install.html#mac-os-x (www.cantera.org/docs/sphinx/html/inst...)

installing brew on SAGE:

sage -sh (& ruby brews formula)

does not use SAGE pythons path.

What can I do? Of course I can get out from Jupyter sage kernel and select python kernel, but....

Filipe

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-10-22 12:02:07 -0500

Flips gravatar image

Finally! I solved the problem.

Installing the miniconda

install sage

install cantera in the sage environment.

Thank you all.

Filipe

PS. Cantera will run well but it seems that sage is running with python3 and so there are some problems (plot3D, list_plot, zip etc.)

edit flag offensive delete link more

Comments

I turned your comment into an answer. Please accept the answer by clicking the "accept" button (with a check mark). This will mark the question as solved.

slelievre gravatar imageslelievre ( 2019-12-24 15:51:49 -0500 )edit

The Python 3 problems should be solved by now. The Sage 8.x series has been increasingly Python3-compatible, and Sage 9.0 will be primarily Python3-based (unless one decides to build for Python 2, which will stay possible for a while).

slelievre gravatar imageslelievre ( 2019-12-24 15:53:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-09-28 02:19:41 -0500

Seen: 165 times

Last updated: Sep 28 '17