Ask Your Question
0

sageserver with ssl and apache as proxy

asked 2017-08-03 04:03:35 -0500

msage gravatar image

updated 2017-08-03 04:12:13 -0500

I configured sagenotebook server with apache as https proxy. I have this running quite a time now.

Now I realized that some requests from the notebook try to get a page with http:// . I assume, it's hardcoded somewhere.

So for a working notebook it is not sufficent to open port 443 in the firewall only. It is also necessary to open port 80 as well.

So if I watch packets, from time to time I get not only encrypted packets , but also some http requests.

It seems that they happen for example if the worksheet list of a user is called

GET /home/anyuser/

or

GET /pub/

or

GET /logout

Has anyone an idea how to solve this?

Maybe in local/lib/python2.7/site-packages/sagenb/flask_version/worksheet.py

the line

addr = 'http%s://%s/home/%s' % ('' if not g.notebook.secure else 's',

could be responsible for that.

But starting noteboook with secure=True doesn't work, and should not be used together with apache as https proxy, I think ??

If I alter the line no change in behavoiur.

Any Ideas?

Thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-08-03 05:52:38 -0500

tmonteil gravatar image

Did you try to enforce https here ?

addr = 'http%s://%s/home/%s' % ('s',
                                hostname,
                                worksheet.published_version().filename())
edit flag offensive delete link more

Comments

Yes, but no effect.

msage gravatar imagemsage ( 2017-08-03 06:55:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2017-08-03 04:03:35 -0500

Seen: 59 times

Last updated: Aug 03