Ask Your Question
1

Can't connect to localhost:8080 in 7.4 on Windows web browser

asked 2016-12-05 22:41:46 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I'm pretty new to this and I'm probably doing something wrong but I tried connecting to sage using localhost:8000 on firefox and it worked until I started a notebook using notebook() after starting sage in the terminal. To go to the next step, it tells me to connect to localhost:8080. I'm unable to do it. Don't get me wrong it works perfectly in virtual box but I can't go further on my Windows web browser. This would be preferable for me to connect via firefox or any other browsers so that I can use my keyboard setup.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2016-12-06 01:31:46 -0500

tmonteil gravatar image

updated 2016-12-06 01:32:00 -0500

Regarding port 8080, you could have a look on Virtualbox settings to see if the port 8080 of the host is binded to the port 8080 of the VM.

Also, you can let the notebook listen on the port 8000 by typing from the Sage shell:

sage: notebook(port=8000)
edit flag offensive delete link more

Comments

Ok so I tried that and it doesn't work. Now it tells me to use port 8001 wich I still can't use. How can I setup the port 8080 in virtual box?

Enderguy_58 gravatar imageEnderguy_58 ( 2016-12-06 09:12:29 -0500 )edit

I tried setting it up like this : random name | TCP | 127.0.0.1 | 8080 | 'BLANK' | 8080

This is in virtualbox. It didn't work. What is wrong?

Enderguy_58 gravatar imageEnderguy_58 ( 2016-12-06 22:20:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2016-12-05 22:41:46 -0500

Seen: 214 times

Last updated: Dec 06 '16