Problem installing SageMath in a MAC OS 10.11

asked 2016-03-30 12:33:31 -0500

anonymous user

Anonymous

updated 2016-03-30 20:42:02 -0500

I tried to install SageMath on my Mac but I've been not able. The install.log is the following. Any suggestions how to fix the problem?


*** ALL ENVIRONMENT VARIABLES BEFORE BUILD: ***
Apple_PubSub_Socket_Render=/private/tmp/com.apple.launchd.lVkhkEeHUb/Render
DISPLAY=/private/tmp/com.apple.launchd.EQE2TENF0c/org.macosforge.xquartz:0
HOME=/Users/Beebee
LANG=en_US.UTF-8
LOGNAME=Beebee
MAKE=make
MAKEFLAGS=
MAKELEVEL=1
MFLAGS=
PATH=/Users/Beebee/Downloads/SageMath/build/bin:/Users/Beebee/Downloads/SageMath/src/bin:/Users/Beebee/Downloads/SageMath/local/bin:/opt/local/bin:/opt/local/sbin:/Library/Frameworks/Python.framework/Versions/3.4/bin:/Library/Frameworks/Python.framework/Versions/Current/bin:/Library/Frameworks/Python.framework/Versions/3.2/bin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Library/TeX/texbin
PWD=/Users/Beebee/Downloads/SageMath/build/make
PYTHONPATH=/Users/Beebee/Downloads/SageMath/local
SAGE_EXTCODE=/Users/Beebee/Downloads/SageMath/local/share/sage/ext
SAGE_LOCAL=/Users/Beebee/Downloads/SageMath/local
SAGE_LOGS=/Users/Beebee/Downloads/SageMath/logs/pkgs
SAGE_ORIG_PATH=/opt/local/bin:/opt/local/sbin:/Library/Frameworks/Python.framework/Versions/3.4/bin:/Library/Frameworks/Python.framework/Versions/Current/bin:/Library/Frameworks/Python.framework/Versions/3.2/bin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/opt/local/bin:/opt/local/sbin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Library/TeX/texbin
SAGE_ORIG_PATH_SET=True
SAGE_ROOT=/Users/Beebee/Downloads/SageMath
SAGE_SHARE=/Users/Beebee/Downloads/SageMath/local/share
SAGE_SPKG_INST=/Users/Beebee/Downloads/SageMath/local/var/lib/sage/installed
SAGE_SRC=/Users/Beebee/Downloads/SageMath/src
SAGE_VERSION=7.1
SECURITYSESSIONID=186a6
SHELL=/bin/bash
SHLVL=4
SSH_AUTH_SOCK=/private/tmp/com.apple.launchd.Ew8hsTGnj3/Listeners
TERM=xterm-256color
TERM_PROGRAM=Apple_Terminal
TERM_PROGRAM_VERSION=361.1
TERM_SESSION_ID=C282CC30-020E-476B-8C1A-848A7B995B2B
TMPDIR=/var/folders/_6/0pq5yd_55ndd9bzsp1v7znq80000gn/T/
USER=Beebee
XPC_FLAGS=0x0
XPC_SERVICE_NAME=0
_=/usr/bin/env
__CF_USER_TEXT_ENCODING=0x1F5:0x0:0x0
***********************************************
make base
sage-logger 'sage-spkg patch-2.7.5' '/Users/Beebee/Downloads/SageMath/logs/pkgs/patch-2.7.5.log'
Found local metadata for patch-2.7.5
/Users/Beebee/Downloads/SageMath/build/bin/../sage_bootstrap/cmdline.py:78: Warning: 'as' will become a reserved keyword in Python 2.6
Traceback (most recent call last):
  File "/Users/Beebee/Downloads/SageMath/build/bin/sage-download-file", line 27, in <module>
    from sage_bootstrap.cmdline import SageDownloadFileApplication
  File "/Users/Beebee/Downloads/SageMath/build/bin/../sage_bootstrap/cmdline.py", line 78
    except TypeError as err:
                      ^
SyntaxError: invalid syntax
make[2]: *** [/Users/Beebee/Downloads/SageMath/local/var/lib/sage/installed/patch-2.7.5] Error 1
make[1]: *** [all-toolchain] Error 2

real    0m0.180s
user    0m0.087s
sys 0m0.086s
***************************************************************
Error building Sage.

The following package(s) may have failed to build (not necessarily
during this run of 'make all'):

The build directory may contain configuration files and other potentially
helpful information. WARNING: if you now run 'make' again, the build
directory will, by default, be deleted. Set the environment variable
SAGE_KEEP_BUILT_SPKGS to 'yes' to prevent this.
edit retag flag offensive close merge delete

Comments

What version of Python do you have installed? What does python --version tell you? How about which python?

John Palmieri gravatar imageJohn Palmieri ( 2016-03-30 20:45:14 -0500 )edit

Python 2.5.4

Beebee gravatar imageBeebee ( 2016-03-31 09:59:37 -0500 )edit

That version of Python is too old. The default version of Python in OS X should be newer than that. Do you have some other software installed which could be providing an older version of Python? (What does which python say?)

John Palmieri gravatar imageJohn Palmieri ( 2016-03-31 16:23:45 -0500 )edit

You're right. Python version was too old. I update it to version 2.7. Tried to install Sage again and it worked. Thank you very much!

Beebee gravatar imageBeebee ( 2016-04-02 16:15:30 -0500 )edit